Why does my particle system look different in editor?

I’ve started playing around with the particle emitter systems, and this confuses me. I upped the rate of particle generation to a very high amount in the editor, but in game it still only spawns particles at a slow rate. It might even only be spawning one item at a time. What am I doing wrong?

Did you save the changes, and drag the particle (from the content browser) into the ‘world’ again?

Hope this helps.

  • Jame Olive

The system spawns into the world/isn’t there when the game starts, but all other changes i make like color/speed carry over, just not the spawn rate of particles

Be sure to see if you accidentally didnt enable LOD’s in cascade.

that is often the reason stuff looks different, another thing is that you need to be sure your engine scalability settings are set to epic.

If that isnt the issue, show us a video/image of whats up, be sure to show the required, spawn, lifetime modules fully.

Thank you! Setting engine scalability to epic fixed the problem.