why does my packaged version have lower resolution?

I’m pretty new to unreal engine so maybe there’s something I’m looking over, but whenever I run the packaged version of my game, its significantly lower resolution. It looks really blurry. In the VR preview within the editor it looks fine. Any ideas as to why it would be doing that?

I have the same problem and the performance is worse as well which is odd.

We really could use a proper packaging guide for vr because there must be a bunch of settings and tweaks needed.

Hey! We had the same problem. It’s a relatively easy answer. In your GameMode Blueprint, use the Event BeginPlay connected to an Execute Console Command with r.ScreenPercentage as the variable. After that, you can choose an oversampling rate that works for your project. If you do r.ScreenPercentage 200 then it’ll run at 200% resolution (or double supersampling) which will clear things up a bit, at the cost of performance. We’re trying to hit the balance between no dropped frames and clarity, seems like the max we can hit is about 150.

I know you can also edit the Screen Percentage inside of a Post Processing Volume as well, it’s under the Misc category.

Hope that helps!

Not sure if it’s the same problem, but i faced low resolution bug on level reloading in packaged game. Resolution of mirror window changed to 720p at this momemt. I resolved it with two fixed:

  1. check IsHeadMountedDisplayEnabled() before call ‘stereo on’ command to avoid double calls.
  2. changed Standalone game window size in Editor Preferences to 2160x1200.
    Don’t know what exactly helped, but now resolution is normal.