Why does mipmaps make textures so blurred from a close range?

I find myself turning mipmaps off in a lot of textures because it makes the mesh look very bad even if i’m very close to it.
I know it is there to improve performances and is supposed to work from long range like LOD meshes, so why does it happens?

You can change the mip map distance -> https://answers.unrealengine/questions/253103/can-i-control-mipmapping-distance-via-material-edi.html :slight_smile:

Thanks! But I have so many assets provided by epic that behaves like that and it doesn’t make sense that finished assets will act like that.
Maybe there is something in the project settings that can cause it?

If you are referring to constant Streaming Textures, try playing with r.Streaming.PoolSize cvar.

Thanks! Setting it to a big number fixed it! :slight_smile:
I’m using 's plugin to import external textures, so maybe they take all the pool space and nothing left for the builtin textures? just a wild guess…