Download

Why does lighting appear different after hitting "Play" than it does in Viewport?

Hello all!

I am writing because I cannot figure out why the lighting in my scene appears differently after hitting “Play” than it does in the Viewport.

In the scene I only have a plane, a point light, and a player start.

Here are the images to show. On the left is in Viewport after Building lighting, and on the right is after hitting “Play”.

in_viewport.jpgin_Play.jpg

This is frustrating because I cannot, at this point anyway, trust what my lighting looks like after I Build because when I hit play it looks very different.

Can anyone please tell me why this is happening or where I can go to control this?

Thank you in advance. I look forward to your responses.

Thanks for your response.

I added a Post Processing Volume and didnt see anything I could turn on or off to control this.

What settings under the Quick Settings tab do you use to control this?

Where are the View Mode tabs?

Thanks!

It’s because of the Eye Adaptation, which (I have found) makes it very hard to get good dark levels that you sometimes really want.

Thanks for your reply. Do you know where to go to seek this out?

In your post process volume settings go to Auto Exposure and set Min/Max Brightness to 1.

This is fantastic thank you! It worked!

I was messing around with these values just last night but didnt put the right numbers in.

Thanks!

Hi , I applied same setting as you guys mentioned but still my scene looks different before and after light build… don’t understand why… if it’s hardware problem ,please mention that too… i am using gtx750 with i5 760 first gen and 12 GB RAM only. Light build is taking almost 1 hr. for this small scene. Please help me out.

So far, I’ve had the best results by turning off eye adaptation / auto exposure entirely. Where it’s darker, it’s darker; where it’s brighter, it’s brighter.
I do need to turn up the lighting in deep dark places compared to “normal” though, or the stark sunlight would have to be entirely blown out, or the dark tunnels entirely black…

Try restoring a viewport, or choosing another one like top, and changing it to perspective and pressing G enable disable game mode and check if that makes any difference. I had similar issue.