Why does Installation stops during Direct X set up?

Hi there,

I have just downloaded the “UnrealEngineInstaller”. It will execute, but after 3/4 of the Direct X installation, it will stop. A desktop icon appears and that’s it. I guess it is not even downloading the complete Engine.

Please help!

Regards

Johannes

At the moment we do not have a confirmation that the installer completed because it should just start the launcher. If you have a desktop icon then the installer completed but it failed to start the launcher for some reason. What happens when you double click the desktop or start menu shortcuts? Do you get any error messages?

If I double click the icon, or use the start menu shortcuts, it seems to load for about 5 seconds, then it stops and nothing happens. No window opens or any error message pop up. Just the blue loading circle above the pointer, which will disapear after 5 seconds…

Hi Joppi, have you tried to uninstall, re-download the msi installer, and re-install yet? Do you get the same results every time?

Hi Stephen,

yeah, tried to uninstall then re-download and install again (probably 3-4 times). Always with the same result.

Regards

Joppi

So since you have a shortcut we can assume your install completed. That means you have the launcher(probably in this folder: C:\Program Files\Unreal Engine\Launcher). For some reason your launcher is silently failing. Usually when users have a launcher issue they are presented with a message describing the error, a message with the associated error code, or a crash reporter window. I have not seen an issue exactly like yours where there is no feedback from the launcher.

Perhaps you could provide us with your newest UnrealEngineLauncher.log. According to this Link, you can find the logs in the following location(be sure to change USER.NAME to your user):
C:\Users\USER.NAME\AppData\Local\UnrealEngineLauncher\Saved\Logs

OK, Here it is

Hopes it will give you a clue link text

Thanks for providing the log! I’m investigating and consulting with some experts at the moment.

This issue is not the same. Please see the following: Link

It looks like maybe the DirectX end-user redistributable didn’t install properly. Could you use the -d3ddebug parameter when starting the launcher? To add this parameter you can do the following:

  • Right click on your desktop or start
    menu shortcut and select
    Properties->Shortcut
  • Add -d3ddebug to the end of the Target path.
  • It should look like this:

  • Hit OK

Once you do that, run the launcher again using the shortcut you modified and post the new log.

Hi!
I have exactly the same problem on my MaxBook Pro with Windows 7 Pro Bootcamp:

Please Help.

for me this is not possible because the installation of the launcher is not completed:

3566-screen_02.jpg

I had a same issue when I install UnrealEngineInstaller it stopped and rolled back in DX installation. I don’t know how it works but after try multiple times the installation went through. However there is a bug like this.

Thank you for the additional insight. I suspect this is a different issue because the original question did not involve a rollback. It seems the launcher installed successfully but is failing to start. We are, however, investigating some issues with the installer failing to complete as you describe.

Hi 0xDEADBEEF,

please find the log using the " -d3ddebug" parameter in the attachment.

Cheers

Joppi

launcher with parameter

Well, the log created when using the -d3ddebug param was not as helpful as I thought it would be. Perhaps we could take a different approach: Could you try to re-install the DirectX End-User Runtimes (June 2010)? The DirectX redist can be found in the Unreal Engine install folder but, to be on the safe side, could you download it from here: Link

When you get the directx_jun2010_redist.exe, it will have you extract the files. Navigate to the folder you extracted to and run DXSETUP.exe. Once the install is done, try to launch Unreal Engine again.

If this does not work, I may have you create a log using DependencyWalker to see if we can spot any issues there. The basic steps are outlined here if you want to get a head start(See Using Dependency Walker section): Link

Well, tried the DXSETUP. Did not work.

Went through the DWalker procedure. You can find the Log in the attachment. Hope you find an answer. Keeping my finges crossed.

Thxs

JoppiDWalkerLog

Thanks! I’m reviewing the logs now and consulting with experts. In the mean time, can you check the following for me:

  1. Do you have a DXGIDEBUG.DLL file in your c:\windows\system32 folder?

  2. Is there a DXGIDEBUG.DLL in your c:\program files\unreal engine\launcher\engine\binaries\win64 folder?

  3. Do you have any files with the .dmp extension in this folder? If so, can you zip those up and post them?

    C:\Users\USER.NAME\AppData\Local\UnrealEngineLauncher\Saved\Logs

OK, I checked the folders in question.

  1. no
  2. no
  3. attached "dmp"link text files from “C:\Users\USER.NAME\AppData\Local\UnrealEngineLauncher\Saved\Logs” folder.

Regards

Joppilink text

I downloaded the executable to install Unreal Engine, but the installation stops at DirectX, and removes the installation. The message is that there is a missing file! The problem appears to be DirectX, thereby if the installation does not include DirectX, it may install. I have previously installed DirectX, but the same problem occurs. Furthermore, the recent installation executable is smaller than the previous. Is this a function of more efficiency or a different installation executable?