Why does Installation stops during Direct X set up?

If you observe my initial comment about rollback, after DirectX was aborted during the installation, this message attached ways obtained.

4851-error.png

Since I tried installing on Windows 7, other Windows as 8 may work. Also, I stopped Windows Firewall, and my antiviral program without success!

Hey Stan, looks like your issue is different than the one in this thread’s original question. In the original question, the install completed successfully but failed to start the Launcher. It would help to get your installer log. You can find some info on how to get the log in this thread( MSI Installation issues ). https://answers.unrealengine.com/questions/17546/how-do-i-get-help-with-ue4-installation-and-setup.html

Hello,

Could you please go to this link:

And let us know if this is the same issue?

Thank you

Hi,

I followed the link and instructions. Everything went well. But I am still encountering the same problem with the UE4 installation launcher.

Regards

Joppi

Was there ever a definitive solution for this problem?

No… I have no idea why they declared it as solved…

That’s disappointing… I haven’t been able to even start mine because the installer won’t download everything… :expressionless:

@Joppi I’m still trying to find a solution for you but I’m a bit out of ideas. Sorry for the delay and thanks for being so patient. If you collect any additional info that you think might help, don’t hesitate to send it my way.

@Tinnyton We have found that sometimes users are not having the same issues. Perhaps you could post your installer logs, Dependency walker logs, and/or any crash dumps that you might have. This will allow us to try and pinpoint your issue.

OK, no problem. I will wait. If something comes to my mind, I will let you now.

@StanTheMan

Since it was determined that you are experiencing a different (but similar looking) issue than others in this thread, we would like to return to the original post you created. We have re-opened the post.

https://answers.unrealengine.com/questions/34588/why-does-the-installation-stop-at-direct-x-and-uni.html

Sorry for the confusion

I believe I’m having the same issue as the original poster. I have a log file but it won’t let me attach it because it’s larger than 512KB. What should I do?

Heya JSpaceman, could you right-click your log and choose “Send To → Compressed Zip Folder” That should get the size down to attach it.

Here is my log file as well. It definitely seems as if it’s failing at the Direct X installation. My computer tells me I have DX11 installed and won’t let me upgrade any further than what I have. I’m running Win 7 64 bit. Help! :slight_smile:

You can try the workaround posted in this thread: Link

Cool, thanks! -That is an improvement… it didn’t fail and gets to the Unreal Engine Launcher! However, the box in the upper left under my name says “No Engine Installed”, and I don’t seem to have a way to install it.-

EDIT: Sorry, I didn’t realize I had to install it from the library. Cool, seems to be working now! Sadly, the visuals of the Unreal Engine Launcher are all distorted and the text is all chunky looking. I’m guessing it doesn’t like my DX for whatever reason - but I have the latest DX11 and it won’t update any further. Any ideas or threads to point to on that issue?

Unsure what the issue might be but you might get more traction if you moved the question to a new thread as this one mainly focuses on the Unreal Engine Installer.

When you run the DirectX install that was linked in the workaround steps, what does the installer tell you? I’m having a hard time picturing what you mean when you say this:“My computer tells me I have DX11 installed and won’t let me upgrade”.

No matter how many times I run that installer, it always proceeds.
What build of DX11 do you have installed?
Are your graphics card drivers up to date?
A dxdiag may tell us if your hardware meets the minimum requirements.