Why does hi resolution screenshot still shows control rig's shape?

I’ve already hit G so pivots and UI elements are hiding.
But. It looks like if you turned on level sequencer and has used control rig before, the control rig is still showing. Is it a bug or is there other elements to control its visibility?
Sometimes the body control shape has a big bounding box only shows in hi resolution screenshot…It does not show in normal editor mode, nor does it show in game rendering mode, it only shows in level sequencer&cinematic view mode.

I’m still hitting this in 5.4, is there any fix or workaround?

I made some test, it looks like that in the control rig’s editor,
for each control shape there is a property called show/hide in render or something.

I only see one visibility option in the properties


Toggling it hides the control, but the helper line is still visible in High Resolution Screenshots and rendered frames
image

I believe it is the “drawing limits” checkbox?

That seems like a drawing limit to me.

Disabling drawing limits works for the fingers and toes, but the option is greyed out for other controls like the elbow

In high-resolution screenshots, the control rig’s shape may still be visible due to several factors. Firstly, the control rig is often an integral part of the animation or scene setup, designed to manipulate character movements or object interactions. Secondly, even in high-resolution renders, certain intricate details like rigging components may not completely disappear, especially if they are not specifically excluded from the rendering process. Additionally, the rendering settings and lighting conditions can also influence how much detail is captured, sometimes allowing the control rig’s shape to be visible in the final output.

A work around I’ve found is to take the High Resolution Screenshot while running the level on Simulate
Alternatively, if you take a High Resolution Screenshot without clicking on the actor/control rig in question after loading the level you wont see any of the rig in the screenshot