Why does Fullscreen Mode fail?

When I try to enter Fullscreen mode via console command or Alt+Enter I get screen flickering and the window instantly minimizes never to recover. How do I fix this?

I get this too. Any ideas?

Hi Omskillet and ,

I have assigned a technician to this issue, but a few more details could help. Could you please post your DxDiags and version numbers? Do you see the minimized screen in your taskbar or does it close the window entirely? Any additional information may help.

Hi again,

I am marking this answer as accepted until you are ready to continue with the investigation. When you are prepared, please post the requested information and we will be happy to further assist.

I am ready to assist with further investigation. I see a minimized screen in my task bar. When I try to maximize it again it continues to flicker. I’ve found that when I package the game and set FullscreenMode=1 in my GameUserSettings.ini I am able to run in fullscreen. FullscreenMode=2 causes the same problem. This is still happening in 4.4.1. I’m attaching my dxdiag as well. I’m running on 2 ATI 7970’s. Thanks!


Hi Omskillet,

Thank you for your response and the additional information. I have assigned a technician with a more compatible machine to look into this further. He will post shortly.


Hi omskillet,

I was able to get flickering on my second monitor while switching between Windowed and Fullscreen, but I haven’t been able to reproduce the minimizing that you are seeing.

After the issue occurs, have you tried hitting Alt+Tab or WindowKey+Tab to try and switch to the window?

Also, you said that you are trying this in a packaged project. Does it also happen when playing in the StandaloneGameMode?


You haven’t replied to the other thread regarding this issue in a while. Are we any closer to knowing why some builds fail to run in fullscreen? It seems to me that it’s a bad config issue but I don’t know how to resolve it.

Yes this happens in standalone game mode. I’ve tried alt+tabbing to no avail. Why does it work with fullscreenmode=1 and not 2? What is the difference between those 2?

Also apologies this is still omskillet. I’m logged in as our studio alias.

FullScreenMode=1 is standard fullscreen

FullScreenMode=2 should be windowed fullscreen mode set to the ResolutionSizeX= & ResolutionSizeY= (but I’m having issues getting this setting to work at the moment.)

I’m unsure of why you’re seeing this on your system, but I haven’t been able to reproduce your results so far. If it’s working for you though, the workaround would be to set FullScreenMode=1.

I have a similar issue. On my Workstation with a Nvidia GTX770 with latest official drivers on two Monitors, i can’t get go fullscreen with alt - enter. Monitors starts flickering and then gets dark(one of them). I have tried the exactly same build on my laptop without any problems. Remove one from the monitors from the graphic card settings makes no difference.

This is exactly the same setup I have - GTX770 with multiple monitors. I also find switching to one screen makes no difference. It’s still broken.

I’ve had some long conversations regarding this issue in another thread, but we didn’t find any resolution. Perhaps the fact we’re both using the same hardware will help narrow it down.

This is the other thread: https://answers.unrealengine.com/questions/84445/43-cant-fullscreen-or-set-standalone-resolution.html

Ok, Problem solved halfway. As mentioned bellow. Set FullscreenMode to 1 in the Gameusersettings.ini and the fullscreen is now working on the Workstation. It’s still a bit strange, that on the laptop the alt-enter combo which seems to call the fullscreenmode=0 command is working, but on the workstation with two monitors is still “crashing”. Also settings via the console is not possible. r.FullScreenMode 1 does nothing when in Window (2) Mode.

Fullscreenmode 1 is windowed fullscreen, which also works for me. It’s not an ideal solution as some functionality probably won’t work windowed, such as an oculus rift.

I don’t see any window frame when i go to FullScreenMode 1. Seems to be the real Fullscreen to me. Maybe it’s hidden behind the real monitor Frame, i don’t know. But now comes the next Problem. Set Resolution in Fullscreenmode doesn’t work. In window mode the Resolution changes accordingly…

So i have done some more testing. It seems we are the unlucky guys having a GTX770 Card :-(. On my Laptop i can change ALL Resolution i want. Even a 1024x768f command gets Fullscreen at 1024x768. Everything is working well. Unfortunally my Laptop has only a AMD Radeon 5600 Series Card build in. So what do now? Are there some recomended cards from epic? The GTX770 has cost me a lot of bucks and i really want to use it in the future.

It should be meant 1024x768f. I would have made the f bold, but thats not working apparently.

Yes, windowed fullscreen hides the window edge outside of the monitor bounds, but doesn’t restrict the mouse to the game window, along with some other behaviours that differ from true fullscreen. There’s also a performance hit.

Hi Tolero,

Most of use here at Epic are using that same card. As long as your driver is up to date and your not using the Beta driver, the GTX-770 should work fine. Which makes me think it may not be the card. What other similarity does your PC and 's have in common?

Windows 8.1 here. Can’t imagine what else we might be trying to hunt down. I don’t have a test machine to do a clean OS install or even a spare hard drive at the moment.

Also I’m positive I have the same problem on a machine with Windows 7 and a Quadro 600.

I’m a version behind on video drivers. I’ll try moving forward to the latest version and see if I still have a problem with blueprints crashing lots and if it resolves the fullscreen issue - although I had the same fullscreen issue with the latest drivers as well.