Why do my textures look so bad in game?

Why do my textures look so bad in game?
in game: in game - Album on Imgur
UE5: Imgur: The magic of the Internet

Play around with nanite settings in your mesh. Settings proxy triangle percent to something higher than 0 should fix you problem but may impact performance. Also if texture streaming pool warning appears, that means you’ve exhausted video memory and unreal will try to scale them resolution down. Try to use lower resolution (2k or scale them manually in UE to 1024).

Greetings @LindenN !

We see that this is your first time posting in our forums! :medal_sports: Welcome to the Unreal Engine Community!

I want you to know that you are part of an awesome community, and we’re very excited to have you as a member! I hope the solutions offered by our fellow community member @Kryciuu are of some assistance to you. We’re one big happy! Happy Creating, and I wish you the best of luck on your project! :smiley:

1 Like

Wrong.
First of all it’s a warning. Not an error.
Usually, warnings don’t change or cause anything at all. They are just warnings.
Like ‘hey what you think is happening is wrong’. Me telling you has no effect on your project, in much the same way.

Second of. The streaming pool can be increased to whatever you think without any issue so long as it remains below 80% of the gfx avaliable vram. And usually even when exceeding that.
To fill the pool at the point of crashing on modern hardware you’d have to really go out of your way…

Even then, the engine won’t “scale down” if anything its going to cause a d3dDisconnect error… or a d3d out of memory error more likely.

@LindenN
Make sure that your display settings aren’t scaled down and upsampled and that your resolution is at whatever the native size of your monitor is supposed to be.

There’s a lot of BS from epic trying to say that the engine works ok because it performs OK when you upscale 1080p since rendering 1080p and upscaling it can be done at modest costs.
While rendering 4k or 8k native the engine grinds down to below 30fps…
I definitwly wouldn’t be surprised if they forced the settings for upscale by default in all projects in an effort to make people think that UE5 is viable :wink:

Oh okay, nice to know that. When texture streaming pool warning appears then in one moment every texture that i have applied in my level got low resolution. Based on that and on documentation which says “The texture streaming system, or texture streamer, is the part of the engine responsible for increasing and decreasing the resolution of each texture” i thought it’s working like i wrote it before. Thanks for clarifying.

New textures added to the pool may get mipped down - if you have mip enabled.
Ones that are already on screen, are usually preserved - mind you that ue5 could be doing something entirely different on this too. don’t really know as I don’t use it.

1 Like

You might want to adjust the lighting. Looks like plain old white light and super bright making everything washed out looking.