Why do my Set Float Parameter nodes not work?

Hi everyone,

As part of something I’m working on I am making a number of icons orbit an sphere, however the types of icons has to change depending on different events firing over time.

As it stands I can see that the ‘Set Float Parameter’ nodes are being executed in the correct order and the execution path seems to reach the end. The problem is that after moving my project from one PC to another, the nodes no longer change anything to my Cascade effect (despite appearing to fire off correctly).

I had the exact same issue last week, and the only way I found to fix it was to create an entirely new particle effect from scratch (despite it being an exact copy of my other effect). Simply duplicating the effect did nothing.

I’ve tried changing the constant values in Cascade to see whether it’s my effect that is broken, however changing these values in Cascade worked every time without fail.

Has anybody else experienced this problem? More importantly, does anyone know a fix / workaround to this problem that isn’t just re-creating a large effect each time?

Setting effect float parameters only works when set through Cascade, setting them using blueprint nodes does nothing.

1 Like

Hi CaptainFacepalm -

In Cascade under the Parameter you will need to adjust your Parameter Mode to Direct:


Thank You

Eric Ketchum

1 Like

Hi Eric,

All of the parameters are already set to direct mode so I’m afraid that can’t be the solution.

Any other ideas?

In honesty it seems like a bug because making the effect from scratch fixed the issue (inexplicably!).


I just figured out what the problem was!

So the parameter changes were being triggered by a matinee event that didn’t happen until roughly 45 seconds into the level. When I tried firing the param changes through key press it all worked perfectly, however I noticed that trying to do the same thing AFTER 45 seconds resulted in no visual change.

From this I figured it must be something to do with the timings, so I tried the key press method again, but this time at 20s in. Low and behold, the 45 second matinee event trigger worked perfectly (as did all subsequent triggers).

After some looking around, I found that “Seconds Before Inactive” setting in the “Particles” tab of the blueprint details panel was set to a value of 1. After switching to 0, the param changes now work perfectly and I’ve experienced no further issues.


I figure it must have stopped working when switching projects due to a change in the length of the matinee sequence (meaning the events fired off later). This was then causing the effect to deactivate itself, meaning none of the param changes actually did anything!

Make sure the your “Seconds Before Inactive” settings are set to 0 for emitters that won’t spawn until later in the sequence (or only spawn them in at the moment that you want to start using them).

I have the same problem,

On event begin play I can set a float value, but after that I can’t, tried both your solution and it’s not working

This solved my problem, and I’m mostly commenting so others can find this solution more easily than I did. I wanted to update my particle system’s spawn scale with an input axis value between 0-1 (float).

As well I should, I exposed the parameter and the system worked in all cases except those where I tried to use the input axis value to set the parameter. It would work being set to a new float value (make float literal), but not to the axis value. As soon as I modified the “seconds before inactive” field as shown in your solution to 0, noticing that mine was also set to 1, it worked instantly.

Thank you so much.