Why do my normal maps look like this?

I baked them out in blender using the bevel shader while following this tutorial: Bevel Shader Normal Map Baking Tutorial - Inside Blender 2.8 for Unreal Engine or Substance Painter - YouTube

Maybe you should show us your produced normal - we can’t really tell what’s what from a rendered image…

To me that looks like a bake with hardened edges. Those ‘seams’ are usually due to rays being cast straight down toward a face.

Hopefully this gives some clues

Here is the uv unwrap and a better pic of the issue

You need to make sure you have smoothing applied to the low-poly mesh when you bake your normal map, like someone else said earlier you have hard edges on the mesh.

Also, for something that simple it would be better to chamfer/fillet the edges, you’ve done some of them but for the ones you haven’t you should just do that to the model rather than use normal maps, because the normal map will take up more memory then it would to just add the rounded edges to the mesh. Also, you’ll get errors in the normal map if you try to render a rounded edge for a 90 degree angle corner edge, you would need to chamfer the edge a bit for it to work properly.

Thank you! This was exactly the information I needed to correct the issue. I needed to remodel it so that I can actually make a high poly model out of it. I do not have enough quads.

I wouldn’t blame the model per-se, but the idea behind it.

You don’t/won’t gain much by using a normal map on this since its not an incredibly high poly mesh.

Consider the normal a way to go from 5,000 tris to 500 or less.

With that said, I would work on the model’s topology a bit.
generally speaking you want to avoid tris and keep quads as much as possible - helps to he able to select Edge loops (since you seem to be in blender).

Another thing to note, in blender, is the smoothing.
For this model I would use edge smoothing - mark the edges you need as sharp and add an edge modifier to the model (with correct settings for it).

depending on the size of the mesh, you may need to just add more or less geometry to get the bevel edge to look correct.

The normal map can come in handy on this, if/when you have a bevel with a lot of geometry and want to move it down to far less (let’s say you have 100 sectors on the high end and 6 on the low end as an idea).

Last but not least, your UV may need to be cut a little better. Generally speaking you want to hide the seams as much as possible, place them in areas that cannot be seen, and avoid areas where the normal map is in use (ei put seams on hard edges that you mark sharp).
You could separate the front portion of this item after the bevel entirely for instance. You could also keep only one of the 2 bent sections your UV map has at the bottom by mirroring the right one onto the left one. (Only the light map needs individual UVs on all faces, the material UV can readily be shared).

hope that helps a bit.

There’s artifacts in your normal map, something isn’t going right with your baking/HP/LP/UVs.

I must have referred back to this message 100 times today as i worked. Thank you so much for your guidance. This was incredibly helpful.