Why do I have black spots on my shadows?

My shadows look really ugly. Why?

You could try setting “Generate Two Sided Distance Fields” I believe it’s called or something along those lines to true in the static mesh window editor just below the material slots and apply the settings and see if that clears it up.