Why do i have an error?

Hi! i have a problem…i was watching the 3rd person power-up game C++ tutorial and in the second video when i created the project and went to visual studio and i had an error debugging the code…The specific error was the following:
The following modules are missing or built with a different engine version:
Would you like to rebuild them now?
I pressed yes and the a message popped out which was: TutorialCode could not be compiled.Try rebuilding from source mauanlly.
Can you help me please?

Hello ,

These are generic messages saying that the build has failed, but don’t give any particular information. Could you open the .sln file located in your project’s directory and then attempt to compile from inside Visual Studio? If you’re not familiar with Visual Studio, you can press ctrl+shift+B to compile it. If it fails to build, please copy/paste all of the information in the “Output Log” into a .txt file and upload it. If the Output Log is not visible, you can bring it up by pressing ctrl+alt+O

Can you give me the error messages that you’re receiving? When are you receiving them? I’ll need more information to be able to help you.

Also, when you try to run the project in debug via Visual Studio, what build configuration are you selecting to do so? Are you using any particular launch commands when attempting this?

i did build on it and everything it’s ok…but when i debug it i have the same result as before!

Well i follow this process: I right-click the project and then i debug it selecting the start new instance. I wait for a bit and then a message popos out and says the following:
The specific error was the following: The following modules are missing or built with a different engine version: UE4Editor-TutorialCode-Win64-DebugGame.dll Would you like to rebuild them now?
If i press yes, the debugging process stops.If i press yes a message pops out and says: TutorialCode could not be compiled.Try rebuilding from source manually and the process stops.
The errors are in the txt file…check it out

84768-errors.txt (23.6 KB)

If i press no* the debugging process stops

In case you didn;t notice I have uploaded the txt file with the errors on the output log

Thank you for that information, . It seems that there are multiple messages mentioning that you’re missing .pdb files. This could be due to your engine installation missing the necessary debug files. Can you follow the solution given on this post and see if it is able to fix your problem?

nope still the same bug…I forgot mentioning that the process when is being debugged is on a debugGame editor and not in the normal which is the development editor

That is, on the grounds that I want to follow a tutorial!

When you got that output log from before, what was the exact process you followed before that log showed up? Also, have you tried to see if this same issue occurs in a fresh project just to make sure that it is this one project in particular? If it is only happening in this project, could you post the code that you’re using so that I can see if there are any mistakes that are causing compilation errors? As mentioned before, “TutorialCode could not be compiled.Try rebuilding from source mauanlly.” means that the code has failed to compile, meaning that there are errors in the code itself which need to be fixed.

Well I just create a new project(third person with c++), so visual studio opens. I choose debugGame editor instead of development which is the usual and I debug it instantly…I don’t write any code in it…just I have these errors…There is no code only a new empty project. Also I’ve tried many times creating new projects but it does the same thing!

The Third Person project does include its own code, as does any code project created with UE4. It seems that you may be missing the debugging files to run a project in debugging.

If you’re using an engine version that you downloaded from the Epic Games Launcher, please open the launcher’s Library tab and click the down arrow beside your engine installation. Under the “Options” selection, there should be a check box for “Editor Symbols for Debugging”. Can you make sure that this option is checked? The files included in that are required for running in debug and are likely causing these problems if you don’t have them.

the option is cheched! To be honest,really, I can’t understand the whole situation!

To see if debugging itself is the problem, could you try building for Development Editor and then opening the project directly? If that works, at least we’ll know that its the debugging itself that is having issues.

When i choose Develpment Editor the project runs normally without errors!

Please try following these steps and see if you get the same results:

  1. Inside of the project’s directory, delete the Binaries and Intermediates folders.
  2. Right-click the .uproject file and select “Generate Visual Studio Project files”
  3. Once the generation completes, open the .sln file for the project
  4. Change the Build Configuration to Development Editor and platform to Win64.
  5. Compile the project (Right-click the project’s module in the Solution explorer and select “Build”, this way we’re sure that we’re building the correct thing)
  6. After that completes, switch the Build Configuration to DebugGame Editor and keep the Platform to Win64.
  7. Right-click the project’s module in the Solution Explorer and select Debug > Start New Instance.
  8. You’ll be prompted to build or not, please select “Yes”

Does the editor open in debug for you or do you receive a similar error?

i receive a similar error. It’s a pop out message which is saying the following: Unable to start program ‘C:\Program Files(x86)\EpicGames\4.11\Engine\Intermediate\Build\Unused\UE4.exe’
Δεν είναι δυνατή η εύρεση του καθορισμένου αρχείου από το σύστημα.(Greek)
In engilsh: Unable to find the specific file from the system.

Usually that message means that you’re trying to run the Editor (UE4) module in debug with a Binary version of the engine. Are you sure that you’re right-clicking the project’s module and not the UE4 module?