Why can't I see other players in multiplayer?

I tried to set up multiplayer myself, and got two windows open ( Client and server ) and could trigger and witness doors opening in both sessions, BUT, neither session could actually see other pawn. So I gathered pawns where hidden for some reason , so I figured I better just look up a tutorial.

I found one of Epic’s official tutorials on blueprint networking, and in this tutorial exact same steps I took are taken, but on their end, in tutorial they can see other plays - I still cannot.

I have been stuck on this for a while now, as it really just seems to be something minor that I can’t solve, it is clear that both players are in session because interaction done in one session are seen by player in other session.

If anyone could give some insight into this, I would be very grateful.

This is a silly response, but have you made sure that player models/components are set to be visible to other players? For instance, in setting up first person shooter you make arms visible to player and body not visible and opposite for other players?

If you’re replicating correctly you’re characters should show. Check if actual mesh/skeletal mesh is set as only seen by owner…
If you are using FPS Template the’re a good chance yes.

Hi, I did think this might be issue, but I can’t quite find any rendering or visibility options on skeletal mesh, could you clue me in to where they should be? I have only recently moved from ue3 to 4 so layout change has slowed me down considerably.

Hey catfisherman,

You can see options Owner No See and Only Owner see in Character Blueprint. Go to Defaults and scroll down to bottom of Rendering section. Click little arrow to expand section, then scroll down until you see options for each of two meshes. By default, full character mesh will have Owner No See enabled, and arms/weapon mesh will have Only Owner See enabled. You want to make sure you don’t have Only Owner see enabled on full character mesh. You can see an example of this in action in ShooterGame in PlayerPawn Blueprint.

Hope that helps!

Just change “play offline” to “Play as Listen Server” or “Play as Client”.