Why can't I play as my character?

So I have a character on a map I’m making and whenever I hit the play button its like I’m in the editor view. I cant move my character, he does nothing and I fly around with a camera view… HELP PLEASE I would like to get back to work on my game and would like to know just whats going on ASAP!

THANKS!

Did you make sure your GameMode is set up to use your MyCharacter correctly?

I’m still confused. I’m quite new to this, sorry, and I’m not quite sure how to do this.

you need to choose a game mode or make a one
go to world settings and select your game mode

I set it to my first person mode but it’s still not working, I just fly around like I’m in editing mode. Sorry if I’m just doing something stupid.

could you post some pictures for the game???
and the character

Sorry its sideways. What is wrong?

117330-img_6302.jpg

Might not be the greatest answer but here’s 2 suggestions:

  1. Make sure the character is placed / dropped in the level.

If that doesn’t solve it remove the character from the level and:

In the Level Blueprint create an Event PostLogin > Spawn Actor From Class (your character, location, ect.) > Possess, Enable Input (or something like that… maybe Set Input? )

117346-img2.jpg

I’m not sure if I did what you meant but its still not working, and I tried replacing the player start in my level. Sorry to bother you I still haven’t quite got the hang of blueprint.

Have you made sure that you have an PlayerStart in the level and have set it to your gamemode in “Blueprints”(at the top of the level editor) then on “gamemode” on either Project Settings or World Override?

I have checked and first person is set for both. Might it just be my buggy computer?

4.13.2 is that not the most recent?

I’m downloading 4.14.0 thanks!

What engine version are you using?

I have the same problem and still haven’t found a solution.
It only works when I click put a player pawn and click “lauch from here”.
*I’m using the download “Shooter Game”

select the character in the level then go to the details panel and look for the pawn section. within the pawn section look for auto posses player and set it to player zero. this will bypass the default pawn to spawn that the other answers are saying to use.

Thanks ! Worked for me.