Why can't I launch my project?


A few days ago I was trying to launch my first project that has C++.
When I clicked Launch, I did start, but always failed.

I tried it with a completely new, unmodified TPS project, it did the same thing.
I also tried to reinstall UE4, didn’t help also.

The attached file shows a log I got after a clean UE4 reinstall and a completely new project.
Thanks for any help!

My log

Hi ,

Do you receive any error message when the project fails to open?

Yesterday installed the UE 4.2 and reinstalled Visual Studio.
It worked fine for 2 launches, then it did the same again

But still, a project that uses the same files, but has no C++ works just fine!

Hi ,

I can start my project up without problem, not even Visual Studio gives me an error.

But when I try to Launch or Package it, it gives me the same error:

Oh, I misunderstood. So you are able to open your project normally in the Editor, it is only when you click Launch in the Editor that you run into problems? Are you able to play the game in editor or in a standalone window?

Exactly. I’m able to Play in both ways, but Launching and Packaging always fails.

I think it has something to do with C++.
If I create a project with no code, that works fine.

Seams, in your Google Drive directory can exists files of autoindexer that can’t be properly deleted( due they used in another program). So, when UBT trying to clean up stagged folder, it can’t delete file, that already used somewhere. And it fails. Try transport you project folder into more… reliable directory, Documents/UnrealProjects for example. Also, try run editor with administrator priveleges.

P.S. Using Google Drive as CVS is not good idea. Better choise - Git. UE4 already have unoffical GitSourceControl plugin. Works great.

Thanks Signa,
I tried moving my project to another “closer” folder, sadly it did not work either.
It seems like my content has something that does not fit in.
When I created a new project in the same new folder, it was working.
I will give it another shot tomorrow and see what happens!

No effect, see my comment above.

Somehow it’s not working.
I tried replacing the folder, I’m running everything in admin mode, but no effect.

So my current status:


  • I can create a project with code anywhere.
  • I can Play them any time.
  • I can start it up, Compile, Launch and even Pack for shipping without one singe error.
  • I can do everything with a project that has no code without problem

Not working (in the case of a Project with code):

  • When I add some assets, I can not do any of the things mentioned above, except Compile and Play.
  • I can not Rebuild my project in Visual Studio.

What I tried:

  • Reinstalling both UE4 and Visual Studio
  • Restart my PC
  • Log off and back on
  • Running everything in Admin mode

I ran out of ideas, this problem is beyond my knowledge.
Thanks for any help though!

Hi ,

I apologize for not following up on this sooner. Are you still experiencing this issue with your projects?

Hi ,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Hi ,

Sorry for not answering before.
Since I had to completely reinstall my system, the problem should be treated as resolved.