Why can't I find a cast node in editor?

I am unable to find a cast node in editor, but I can perform casting in other blueprint scripting windows. Is this a bug, or am I just missing something obvious? My goal is to cast that object to a PrimitiveComponent to add it to PhysicsHandle to grab it.


What happens if you turn on Context Sensitive search? From your screen above, it appears to be unchecked.


I tried it both ways. It was originally checked and no cast options appeared, so I tried unchecking it. Still no cast nodes.

It appears that this was actually a bug in editor. editor eventually crashed a while later, and I just relaunched it. Now casts are appearing like normal. Not sure what caused bug, but it was fixed with a simple restart.

I can confirm I have had this same issue after going to 4.1 . My workaround is to go to another blueprint, get cast to node I want and copy paste it where I need it. It has happened to me many times with project I started on 4.0.1 and converted to 4.1 . I am not sure if conversion is related and am unable to reproduce this with new projects.

@canl I only just downloaded UE4 a few days ago and have only ever used 4.1.0, so I can confirm that upgrade is not part of issue.

This is still a bug, 4.2, context sensitive unchecked and I get no casting options, even in empty space or coming off a simple branch node. Win7.

Actually, my problem was that I had to drag off a “childactorcomponent” and “getchildactor”, then drag off that I was able to get casts to show up.

Same problem here, but restart does nothing :confused:

Same problem , anyone got a solution ?

Hey Madness,

What are you trying to cast to, and from where? If you could provide a screenshot, we might be able to see what’s going on. Thanks!

For me, context sensitive box is solution. Not sure why that is, but no cast nodes appear if I don’t have that checked. They only appear if I’m pulling a wire from something that can be cast to as well though.

I just start engine for taking screenshot , but now it works ! , i think when it can’t see theses nodes i should save my blueprint then , restarting engine.

Glad it started working for you. It seems that sometimes Editor doesn’t show cast options properly, and restarting fixes it. I will let developers know. Thanks!

me too , dont know why, I also have to pull a string off something

That’s expected behavior. If you have a reference to another Actor, you can pull off that reference to make a Cast To node. It will not appear without that reference.

This context menu sometimes doesn’t show up as it should. I found only way to get it to appear is to exit editor and then restart. On restart it appears as it should… Very odd and really wish it would be fixed by Epic as it has been a issue for some time now.

Hey all,

There are some known issues with context menu in 4.5, and they have been fixed with a new menuing system which should make it into 4.6. Until then, you can go to Editor Preferences > Experimental and enable Use New Blueprint Menuing System. This will fix many, but not all, of issues currently present with context menu in blueprints. As a side note, you may need to switch this off and then on, as casting options don’t always show up with it on, but should when it’s off.

Thanks for your patience as developers build a better menu system!

You should put a note about this in documentation. It would have saved me hours and hours of headache if it had been annotated somewhere other than message boards. :stuck_out_tongue:

I’ll talk to our documentation team about it. Thanks!