Why can't I create any c++ projects with any engine?

never mind , i found the problem, visual studio doesn’t want to recognize c++ as a language program,i’ll try to install the x86 version of c++

Hi Shadow5455565,

Did installing the x86 version of C++ solve the issue for you? It would be useful to have this information to future users who may encounter this problem if so. Otherwise, I’ll be happy to assist you further if needed.

still not working, and i can’t uninstall vs,but now i can use c++ on vs but ue still not find cl.exe,i’ve installed vb express too

vs*,sorry.

Which version of Visual Studio are you using?

These are ok from my understanding
VS2013
VS2013 Express
Maybe VS2010 version with Express

VS2015 Doesn’t work I believe.

Another Thing to look at is the Build, Are you building in Win32 or Win64, I think the engine is precomiled into Win64, please correct me if this is incorrect.

i use vs 2013 express and community(i can’t uninstall community) and Win64

now on visual studio i can’t create any c++ project,too.

Do you mean that you are unable to compile in visual studio even when attempting to create something that isn’t related to UE4?

i can’t create

i can’t create anything on vs , when i try to create a non ue project too

Wow… ))))))))))))))))))))))

does ue use the VS120COMNTOOLS to find the path of the cl.exe file?
BEcause i modified it but the same result, now i’ll try to copy the cl.exe file that i found on the vs11 path to the vs13 path

fixed up, but new error , it can’t compile my project ; The project could not be compiled. Would you like to open it in Visual Studio?

Running D:/programmi (x86)/Epic Games/4.8/Engine/Binaries/DotNET/UnrealBuildTool.exe testcpp Development Win64 -project=“D:/UE$Projects/testcpp/testcpp.uproject” -rocket -editorrecompile -progress -noubtmakefiles
Parsing headers for testcppEditor
Reflection code generated for testcppEditor
Performing 10 actions (4 in parallel)
[3/10] Resource PCLaunch.rc
[2/10] Resource ModuleVersionResource.rc.inl
D:\programmi (x86)\Epic Games\4.8\Engine\Source\Runtime\Launch\Resources\Windows\PCLaunch.rc(10) : fatal error RC1015: cannot open include file ‘windows.h’.
D:\programmi (x86)\Epic Games\4.8\Engine\Source\Runtime\Core\Resources\Windows\ModuleVersionResource.rc.inl(3) : fatal error RC1015: cannot open include file ‘windows.h’.
fatal error C1510: Cannot load language resource clui.dll.
-------- End Detailed Actions Stats -----------------------------------------------------------
ERROR: UBT ERROR: Failed to produce item: D:\UE$Projects\testcpp\Binaries\Win64\UE4Editor-testcpp.dll
Total build time: 17,93 seconds

i opend it , but the same error in vs

Hi Shadow5455565,

From looking at the error that you provided, it seems that there is a problem with your Windows SDK, either it is missing or it is corrupt in some way. Please refer to the following page from our wiki to solve this issue.

Hope this helps!

Thank you, I just discovered the missing file, cl.exe in VisualStudio13/VC/bin/amd64/cl.exe

New error,but i installed the sdk

Error log

It seems as though the main problem that you’re experiencing is that the compiler is having issues attempting to include the file “windows.h”. Information about that error can be found here:

the 2013 version of vs doesn’t work , but the 2015 works very well, does the 4.9.1 engine version work on vs2015 express edition?

As of now, Visual Studio 2015 support is still considered to be experimental and isn’t recommended for development use. If you do wish to use 2015, I would recommend using a source version of the engine downloaded from GitHub to do this and follow the steps listed here: