Why can't I build the Code first person project with VS 2010?


My name is Matt and I just bought Unreal 4 yesterday and I am trying to figure the system out, I looked through the forums already and I can’t seem to find the answer to my problem.

I downloaded this yesterday, downloaded the shooter game and that ran fine so I think I set that up correctly.

When I tried to build the C++ first person project, it will not build though.

Steps I did:

  1. Started unreal up.

  2. Selected new Project, Selected First person project C++, named it FPSTest.

  3. It loaded up into Visual Studio 2010 (so far so good).

  4. When I tried to build the Debug game though, I get these errors below

    Error 2 error : Failed to produce item: C:\Users\Matt\Documents\Unreal Projects\FirstPersonTest\Binaries\Win64\UE4Editor-FirstPersonTest-Win64-DebugGame.dll C:\Users\Matt\Documents\Unreal Projects\FirstPersonTest\Intermediate\ProjectFiles\ERROR

    Error 3 error MSB3073: The command ““C:\Program Files\Unreal Engine\Unreal Engine\4.1\Engine\Build\BatchFiles\Build.bat” FirstPersonTestEditor Win64 DebugGame “C:\Users\Matt\Documents\Unreal Projects\FirstPersonTest\FirstPersonTest.uproject” -rocket” exited with code -1. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.MakeFile.Targets 38

    Error 1 error RC1015: cannot open include file ‘windows.h’. C:\Users\Matt\Documents\Unreal Projects\FirstPersonTest\Source\FirstPersonTest\Resources\Windows\FirstPersonTest.rc 11

I have not changed anything in the code at all. Is there something I am suppose to do first to run it? I don’t have the engine source code yet, is that why? Also is there a way to show the editor so I can see where this code is attached to on the player?

Thank you!

Hey omalleym,

Thanks for your question! If you are creating a new C++ code project from the Launcher version of UE4, you will have to upgrade to Visual Studio 2013 Express (available for free) or Pro. If you update to VS 2013 and are still having issues compiling a new code project, please let us know.



Hi Steve,
Thanks for the info. Wasn’t aware that my 2010 won’t cut it. I will try that and let you know.

Yup that worked! Had a problem getting the game to cook, but I found that you had to do development editor, go to file, and select cook for Windows and I am able to run now! Thank you very much for your quick response!