Why are there black spots on static mesh?


I have a problem regarding black spots when building light for static objects. I DO UNDERSTAND that there are related topics to this question however I did not understand the answers given. Since I’m just a student perhaps someone could help and explain the problem in a simpler fashion.

My UVs are not overlapping however i do have 2 texture sets. If you need any additional info please just tell me.
Me and my project group are stuck on this.


Still a problem.

I have the same problem. I thought there’s a problem with the normals but I double checked them and they look fine.
I really don’t know what’s happening.

Try creating a “light-map” of your own in Maya (or whatever 3D software your using) instead of the engine making one for you automatically. That solved the issues for me, now I do that for every mesh, have not had the problem since.

Not sure if this qualifies as a solution. The engine should be able to build the light map. This way you are forced to create the scene 2 times, once in Unreal and once in the modeling software.

Well, Im just a student, that is how I solved it, if you have a better solution let me know please.

I’ve had these problems also until now.
I discovered there may be multiple causes to this.

  • Lightmap Resolution

Yes, it may be as simple as that. The lightmap resolution of a mesh is set to 64 by default, which is insufficient for a larger object. Try going to the static mesh options and setting it higher and see how it goes. Also, make sure that the resolution is not overridden in each the static mesh instance options.

  • Incorrect Normals

Make sure that all your normals are facing the right way. Try recalculating normals inside of your modeling software.

Then, if you import your mesh and you get an error saying that there are no smoothing groups, that usually means that Unreal didn’t get all the normal information about the mesh. Try to export the mesh with different settings (edge smoothing, face smoothing, normals only, etc.). If it still doesn’t work, try an older version of the export plugin (for FBX, especially).

If it still doesn’t work, go into the static mesh options (in Unreal) and try checking/unchecking Recompute Normals and Recompute Tangents and see how it goes.

  • Extreme Lightmap World Settings

If none of the above worked, you’ll have to look into Lightmap options under World Settings. If you have set crazy values in there, it may generate lighting artifacts.Try to copy these values from an example project that you see in the example tab, like the RealisticRendering project. This will initialize your lightmap settings with values that have been tested and are known to work.

  • Low Lighting Quality

Finally, if you still have small lighting artifacts, it may be that you have to build lighting at a higher quality. You can set the different lighting quality options when you click the small arrow near the Build button.

I understand, but you may be wasting your time. This should be done in the engine itself. Check out my answer below and see if it works. For me, it solved the problem.

I will try this out on the next import, when I am done with it. Let you know. Thanks.