Why are my materials partially messed up when upgrading from 4.14 to 4.16? Is this a bug or no?

It’s easier to explain with this video:

So as you can see, when I mouse over that node, you can see that the material changes on the left-hand side. (It also sometimes happens in the viewport too on the mesh itself)
This only happened right after I upgraded my project from ue4.14 to ue4.16. It’s not supposed to do that, obviously. So as a result, this causes part of any mesh I apply this to, to be totally borked, with no textures. Any idea what causes this? These textures are from the marketplace called Supergrid starter pack. And all of the textures are all messed up like this. Is this a bug, or some weird hidden setting somewhere that is flipped on by default when version 4.16 is launched? Because when I mouse over a node, the texture behaves as how it normally should.

I’ve tried to google my issue, but can’t find any answers.

Also, there’s another weird change that I’m not used to but when I play the level and exit, I used to hear a sound effect after I hit the escape button, but now it’s gone. Not a big deal, but I kinda liked it. But the point is, it makes me think maybe it is an issue with my ue4.16 download itself that is causing my material issues?

EDIT: I tried upgrading to 4.15 before 4.16, but still I get this same problem :(((