Why are my imported models materials rendering with transparent holes?

Hi Virtuosic Kitty -

It looks like you have some polys that have inverted normals. Look in your modeling program and look at those particular areas and see if they are flipped or inverted. It should be as simple as selecting those polys and inverting or flipping them and reimporting your model.

Thank You

Eric Ketchum

So I imported a character model that had been made and rigged. But as soon as its textures and materials were applied it went pretty funky and has patches on the model that are transparent. and the actual material file doesn’t have those patches missing. Just wondering may know what the problem might be.

here, I have provided a link to an image of what I am getting to help explain what is meant.

Thanks in advanced. :slight_smile:

It looks like either the mesh has missing polygons or flipped faces. Enable two sided in the material properties and see if it fixes the issue. If it does, that means the mesh has flipped faces for some reason and you need to fix it in your modeling software.

Yeah from the first answer I was given I then decided to try making the material 2 sided… didn’t work so I knew it wasn’t flipped faces. Thats annoying. because this software shouldn’t be doing this to the models.

Thanks for your response. it made sense to suggest that being the problem so my instant reaction was to turn the materials 2 sided… it didn’t show up still. so I am guessing it isn’t flipped faces.

Well then the next thing you can do is check if the model has open edges and unwelded vertices in your modeling program. What are you using, by the way?

unfortunately… I am using a Character Creation tool. Fuse. Others have been fine from what I have seen. :frowning:

But I just looked at the wireframe and it does look clear to me that there is missing Polygons. :confused: but when I run the game as the character it flickers between fully textured and the one that is currently with gaps. which makes no sense… I dunno lol. going to try importing a fresh Model and see what happens!

ahh, Looking at the Wireframe it looks clear to me that there is obviously missing polygons… but why does it keep flickering with fully rendered model and the one with wholes? I am going to try another model and see what happens!

I have used Fuse recently and didnt have this problem. Can you post a screenshot of the model without the material as Eric suggested? And the import settings as well please.

Interesting… Can you post a screenshot of the wireframe and Lighting Only mode for the model?

Thank You

Eric Ketchum

okay here we go… so i removed all of the textures and this is what I get blank

as i said I will give another Upload, Rigging and then download a go again.

okay so here is a fresh one that I had put together the other day and uploaded rigged, imported and this is just… WTF! :stuck_out_tongue:

When I save, I am supposed to go for the basic FBX not the Unity one aren’t I!?

Yeah, not the Unity one. Do you have 3ds Max or Maya? If you do, import the model into one of those and then export again. That’s how i do and maybe that’s why i havent had any issues.

Thanks for the suggestion I know you can trial Maya… so i’ll give that a go :slight_smile:

Hi Virtuosic Kitty -

Jacky is correct with the importing into Max or Maya first should fix most of your issues. If you would not mind, could you send us the original imported filed with the errors? We are always looking to improve our importing abilities and this could help us better anticipate issues in the future.

Thank You

Eric Ketchum

anything to make the best engine better! :smiley: I have provided a dropbox link, please notify me when you have received it as I will be taking it down immediately. Thank you. :slight_smile:

Just to let you know. Maya Has fixed it thanks soooo much! could you please write it as an answer. and I will verify as resolved!! Thanks again! :slight_smile:


Thank You

Eric Ketchum

I have the same problem, I’ve made some assets in Maya and it imports with these triangles missing in UE4. I’ve tried reimporting it to Maya and exporting it again, but the problem still presists.

The original question was related to Mixamo exports. Yours may be caused by something you did wrong in the modeling process. Try exporting with different export settings. If they dont fix it check out your mesh in Maya to figure out what may be wrong(I dont use Maya so this is all i can help.)