Download

Why are my baked shadows worse quality than dynamic, even at high texel density?

I’m trying to bake a scene with heavy use of static foliage, however, I’m having a lot of trouble getting the shadows to bake appropriately.

Even at 2048 resolution on the cubes lightmap, the shadows are pixelated and don’t include any of the strands of the foliage. Using dynamic lighting, I can see the strands. Am I doing something wrong? I need to be able to see individual leaves etc. There is a lightmass importance volume included.

Thanks for any help

Hi!

I think you’re a bit confused… if it’s dynamic lighting there is no light baking and no use of lightmap uvs and resolution!!
If static lighting: could you show us your lightmass settings? Maybe it’s set to too low and that’s why you won’t get proper results…

No confusion, I am just pointing out that I would like my baked shadows to be as detailed as the dynamic shadow. When I do dynamic lighting, I can see the individual strands of the foliage in the shadows. When I do static lighting, it’s pixely gray blobs and when the foliage is too thin, no shadow at all, even at 2048 resolution on the cube.

My light mass settings are all at the default and I am building at production quality in the editor. The only thing I have changed is the override light mass resolution on each of the meshes to the values shown in the screenshot.

As you can see in the screenshot I tried a variety of texel densities for the lightmap resolution and my UV maps seem correct. Nothing overlapping, all set in UV1 channel.

Well depending on the amount of lighting information: sometimes a 2048 res lightmap is not enough!!
Default lightmass settings: it won’t calculate smaller setails than 1 cm!! Also it uses compression which will produce “dirt” and inaccuracy!!
Usually when you have a lot of small detail like foliage you should consider to use a Stationary light and use cascaded shadow map for those tiny details!!

Hmm I see. I guess I overestimated how powerful static lighting was. I thought you could use it to make photorealistic scenes. Thanks

Oh of course you can!! :slight_smile:
One of the most important thing is that you set lighting information in pixels!! Like a map…
Lighthing is not “automated” as it is not in any othe software… you’ll need to change settings to achieve what you want… same with Unreal: with proper settings you can achieve photorealistic results!

Well thats what I wanted to know actually haha. What settings do I change so I can get high detailed shadows? Because even at 2048 resolution, they are pixelated and non-detailed.

heres some excellent resources to get you started on lightmass:

https://evermotion.org/tutorials/sho…g-for-arch-viz
(goes through some of the lightmass settings and post process) (even though its for archviz, a lot still applys to everything else)

https://forums.unrealengine.com/comm…-tools-ue-4-23
(physical lighting tools made by Chroman) (supercool but advanced)

https://forums.unrealengine.com/deve…s-gpulightmass
(Luoshang’s GPU lightmass) (GPU lightmass solver-intermediate-can get much better results than cpu lightmass)

Daedalus’s lighting academy series (a very in-depth look at lighting/color theory)

https://forums.unrealengine.com/deve…tmass-tweaking
(older thread-contains koooolalala’s lightmass settings as well as a host of good infomation)

(koooolalala’s youtube page)

Thank you so much! This feels like a treasure trove. Much appreciated!

Static lighting quality is really dependant of your world settings. Even lightmaps with enormous resolutions are unusseful with bad lightmass settings. Take a look at this Masterclass where they explain deeper into this settings

Have you tried increasing “Export Resolution Scale” in the foliage’s details panels? Also in World Settings, the Direct and Indirect Illumination Occlusion Fraction settings could be changed to increase shadow contrast with the surrounding lighting, which could result in sharper, more detailed shadows. There’s a number of other settings in World Settings that could do it too, I think. Check this Lightmass doc page for a reference of the World Settings definitions and other Lightmass aspects. Too much indirect lighting intensity could also be a culprit.