Why AO appears on soft edges?

Every time when I export even very simple static mesh from Maya this dark stripes appears on the soft edges of the mesh. It is noticeable only on the dark side of the mesh and only then I zoom in.
I checked light maps many times and tried different export/import settings - it doesn’t make any sense. The only one thing I’ve noticed stripes go away when I turn off AO in “Show” settings. But I dont have any AO on the scene. It is disabled in Lightmass world settings even. In the same time simple meshes from default “Basic” tab look good.
Do you have any idea what could be wrong with my