Why ambient occlusion on post process doesn't work anymore?

I tried to add some ambient occlusion in my post process but actually there’s no effect with the intensity and the radius. I tried the same thing in 4.15 and it works perfectly. So I assume that there’s a “bug” in this version. I’m using the 4.16.1 by the way (the only available at the moment)

EDIT: I want to add that I tried with AND without forward shading, and with Generate Ambient Occlusion checked on lightmap settings (but it’s not what I want, I want to have the possibility to edit it realtime)

1 Like

Just tried, I does work.

Make sure it’s enabled in the scalability settings.

SSAO (PostProcess AO) is not the same thing as DFAO (Lightmap).

Thank you my friend, in fact r.AmbientOcclusionLevels had 0 as value, so I switched it to 3 and then it worked.
I’ll remember this for the future.

Can you mark this question as “resolved” for other users can find the answer for future problem?

Thank you.

I discovered the reason why my project was completely missing AO, SSAO, etc. (buffer visualization>ambient occlusion shows pure white). because of the DefaultScalability.ini in the [project name]/config folder.

I basically copied all of the text in UE_4.25\Engine\Config\BaseScalability.ini to that file, restarted UE, and now it works! This was an annoying issue as no one else had quite the amount of complication which I was experiencing.

This is a VR project which had been started years ago (back with UE 4.18, I believe). At that time, Epic was recommending to turn of AO for VR, because it was too expensive, and blah, blah, blah. They always are changing their mind (I still love you, Epic!). This must have been the reason that these settings were completely wiped out. It’s either that, or it occurred when I manually converted the project engine version from 4.22 to 4.25.

Oh yeah–And, if you have AO, but it is only baked and no SSAO, that seems to be something which was “recommended” in the tooltip, although not required (as you can always easily turn the intensity of the SSAO to 0, in the post process volume). It was the Direct Illumination Occlusion Fraction and Indirect Illumination Occlusion Fraction. If those are set to false, only static (PrecomputedAOMask) ambient occlusion.

 *Update: Oh, I see. The tooltip states that those values should be set to 0.0 if you want the precomputed AO mask *only* (which would be for procedural grime and material blending, etc.). If you want both the mask *and* real-time AO, those should be left alone.

Set those back to their defaults (with the yellow arrow)>now the ambient occlusion is adjustable in the post process volume.