Why am I seeing NavMesh issues in 4.3?

Here are several issues our team has run into while using Navmesh in version 4.3:

  • Navmesh bounds volume will not update when rotated
  • Navmesh won’t work on meshes that are scaled
  • Navmesh Preview won’t update

Rebuild navmesh.

Yeah we tried that numerous times with no luck.

Hey renderman09,

  1. Nav Mesh should update when you rotate NavMeshBoundsVolume, but it looks like it isn’t creating angles consistent with a rotated volume; instead, it makes a square based on corners of volume. Is that what you’re seeing, or is there something else going on? I’m going to check with developers to see whether this is intentional.
  2. I have not had any trouble with scaled meshes, though scaled meshes are known to cause other problems and it’s generally better practice to make sure they are roughly correct scale before importing them. A couple things to check: In Project Settings > Navigation Mesh, do you have Rebuild at Runtime enabled? In Project Settings > Navigation System, do you have Build Navigation at Runtime enabled, and Dirty Areas Update Freq set to 60.0 or so?
  3. When you say Navigation Preview, are you referring to green field in Viewport? If so, it should be updating if you have your settings as mentioned above.

If you have more specific details about what’s not working and under what circumstances, I can help investigate issues you’re experiencing. Thanks!

  • It seems that when volume is rotated, it snaps back to its original rotation.
  • Yes we are still getting used to import scale settings. I will check on Rebuild at Runtime and Dirty Areas Update.
  • Yeah green field. It used to update with last version. Doesn’t seem to work consistently in this version.

We found an option for converting collision boxes into convex collision under mesh properties. This may have fixed Navmesh not recognizing mesh, but some of other problems still exist.

  1. I’m not seeing that behavior. I’ll keep messing around with it to see if there’s a setting I’m missing. If you wouldn’t mind, can you create a new project from Top-Down template, find NavMeshBoundsVolume1 in Scene Outliner, and rotate it? I’m curious if this is specific to one project for you or if it happens in each project. Thanks!
  2. Please let me know what you find with those settings.
  3. Same as above… I suspect adjusting settings will fix this issue for you.

Thanks! Let me know what happens.

after updating to 4.3 navigation was woking fine for me but preview window always stated that navmesh needs to be rebuilt. but now since I’ve moved some static meshes in level I’ve got same problem stated above and will navigation not work at all.

I’ve found a solution for this that fixed it for me. in my project in 4.2 i had disabled (unchecked) “update navigation automatically” in Editor Preferences as it was taking to long to place meshes. since i updated to project 4.3 i could not enable it as Editor Preferences in menu had disappeared. i work on a mac and found Editor Preferences has moved to Apple tool bar. so enabling “update navigation automatically” has got me working again although you’d think Build at runtime settings should have worked anyway.
hope this helps, let me know.

Hey ,

I have same questions for you as I do for renderman09. Please let me know if you get chance!