Why am I having this weird issue with normals?

Like you need to smooth your model before you import it to Unreal Engine. It doesn’t look like you’re smoothing groups are set up for your normals.


I have been struggling with this for the past few days. I sculpted an anvil for a demo reel in mudbox and also baked in mudbox. The results appeared clean enough. In both maya and marmoset, the anvil looks the way I want but for some reason, once I bring it into the unreal engine, there is waviness in the specularity, the edges appear harder with less detail and the textures washed out. My main concern is the issue with the normals. Looking at the normal map, I can see where the waviness comes from but I dont understand why it appears much worse in unreal and it seems perfectly fine in mudbox, maya and marmoset.

So how can I get unreal to show the anvil as it appears in the first and third example. The first is maya, the second picture is in unreal and the third in marmoset.

I smoothed it before exporting it and I also turned on the smooth mesh option in the fbx export settings. No change. What exactly do you mean by the smoothing groups are not set up for my normals?


I think you need flip green channel in your normal map.

This is texture which was baked in MAYA. In UE4 it looks not right.

With flip green channel it looks the same like in MAYA.

When you see normal map in Photoshop and see elements in normal which must directed upside you must remembered in UE in normal map this object must be look inside. For fast decision this trouble, you must invert green channel in normal or find in UE line with name “Flip Green Channel” from texture attributes and mark this line for positive result. Then invert green channel in texture normal map not required.

I thought I already tried it but apparently I forgot to save after checking it. It worked thanks a lot!