Why am I getting an Invalid Bind Pose error?

So I’m very new to animation and hardly have a clue of what I’m doing.
I just imported my skeletal mesh and I get an error saying that “FBX bind pose 'BIND_POSES” is invalid. It will be ignored". When I later try to attach an animation to this skeleton It gets cut up into tiny pieces and doesn’t look right.
I’ve exported the mesh from 3DS.

I’ve been trying to find help with this but I can’t really find any useful information.

Would love to get some help.
Thanks in advance!


Do you mind sending your .fbx files (like your skelMesh and one animation)? I’ll be happy to take a look at it when I get a few minutes.

In the meantime, in the Skeletal Mesh import options, do you have ‘Use T0 as Ref Pose’ checked when you’re importing your mesh? I imagine you’ll get that bind pose error either way, but it may change what you’re seeing with your animation being all broken.

Thanks Ray!
Here’s a link to the mesh with the running animation Human4_anim4

I’ve tried importing it as a skeletal mesh and then an animation attached to the skeleton. First the animation imported laying on it’s back, I solved this by adding a root joint at 0,0,0. Now it gets imported with the right angle but it’s cut up into pieces like I said, and for some reason it doesn’t play the whole animation anymore (it worked fine before I added the root joint).

I tried the “Use t0 as Ref Pose” option and don’t get one of the errors saying “Warning the following bones are missing from the bind pose…” anymore but the mesh is still in pieces.
I did try to change translation retarget to skeleton on all of the joints instead which made the animation whole but it’s still not playing all of it and it’s in a weird position and size.

Here is the skeletal mesh that worked but didn’t have the root joint which caused animations to get flipped on their backs:

Here is an animation I used that worked but got flipped:

Once again, I have hardly any experience with animation and might have completely screwed up. The animation worked perfectly in IKinema WebAnimate but gets flipped when I import it into UE4.

Got help from someone on the forum saying that the mesh and skeleton have different scales, which turned out to be true, this caused the animation to behave strangely. I can’t figure out how to fix it without loosing my skinning though. I’ve tried saving enveloped, removing skin and then reapplying them after I’ve reset xform but this caused it to behave very strangely.

Hi there,
I just got a chance to take a look at your .fbx files. There are a few things going on, but like you said, the scale is probably the biggest issue. It’s generally a bad idea to have scale on your joint hierarchy in your default/bind/skin pose. You’re free to scale things in your animations, but your bind pose should be clean. In the Human4_Anim4.fbx file, the hip joint is being scaled by 10 in XYZ. I think this will actually no longer be a problem in the next UE4 release (see Lina’s response to this question: LINK). Regardless, it’s still not a very good practice to have scale on there in the bind pose if you can possibly avoid it.

Another issue, and the reason for your invalid bind pose message, is the bind pose does seem to be broken/missing from those .fbx files. I tried importing it into Maya and Max and in both whenever I tried to go to bind pose (assume skin pose in Max), it just showed the pose from the first frame of your anim instead of the correct t-pose one. It’s definitely a best practice to keep a clean file with just your skinned character in its bind/skin pose without any animation on it. Then, use this clean file as your Skeletal Mesh import. That way, if your stored bind pose is a little funky for whatever reason, the ‘Use T0 (time/frame zero) as Ref Pose’ option will still give UE4 the correct base pose.

So, in summary, the .fbx that you import for your Skeletal Mesh should have the character in its t-pose with no animation on it and 1.0 scale on every bone. After that, the fbx’s that you import for your animations can have all the scaling you want. This may require a bit of rework for you, but now is the time to fix things before you’ve generated a lot of animations/content with these assets.

Good luck!