Download

White texture?

[spoiler]f35a6809da14691f08a287e86c6191860c445ec8.png[/spoiler]

I don’t get it, it’s got a texture, but in the material editor and in the game/viewport it’s white??

Here is the image of the actual model in the viewport:

8b7e6475de4fb61f344309c371ae0f8ffd38c912.jpeg

Hi TVGinn,

It’s coming in full white because you’re adding the two images together with this node. The a value of 1 for the unused pine will default to 1 allowing the white to overpower the base texture.

You can you read more about this node here: https://docs.unrealengine.com/latest/INT/Engine/Rendering/Materials/ExpressionReference/Math/index.html?utm_source=editor&utm_medium=docs&utm_campaign=rich_tooltips#add

If you’re just trying to control the brightness of the texture I would suggest using a Multiply node. A value of 0 will darken the image to full black. A value of 1 will be the default color. Any value higher will result in brightening the base image.

I hope this helps.

Thanks Tim, that worked! My next problem is it blurs if I go too far from it in game AND in the viewport. Is there any way to fix that? When I’m right next to it in either of those it’s clear and crisp, but more than two meters away it’s really blurry.

Hi had the same problem you can double click the texture and simply tun off mip mapping in the drop down option

That’s not recommended, because it will be bad for the performance. :slight_smile:

Probably this will help you:
"I found out you can adjust the distance of the texture streaming using the “Streaming Distance Multiplier” setting in the mesh window. Since I create my models in meters and have to set the build scale up to 100, I figured I need to set the Streaming Distance Multiplier to 1000 to get it look right. I hope this helps! "
https://answers.unrealengine.com/questions/12910/bug-mip-map-are-too-brutal.html