Where's OnMoveCompleted gone?

I’ve just updated from 4.2 to 4.4.1 and it seems AIController has gone and there’s now just controller left in it’s place.

The only issue right now is OnMoveCompleted is now missing. I’m not sure if this is intended or something has gone wrong?

Anyone else had this issue?

Hey mate,

I’m on tag “4.1.1-release” and just found:

/** Called on completing current movement request */
virtual void OnMoveCompleted(FAIRequestID RequestID, EPathFollowingResult::Type Result);

on line 151 in 'Engine/Source/Runtime/AIModule/Classes/AIController.hpp"

Did you add AIModule as dependency to your game module?
Seems like it is no part of the Engine module anymore since 2014-05-29: (git log)

SHA-1: fea9d66d252261f698a7d758bd0565453b39abf8

  • Extracting AI code from the engine into a separate module, pass 1 #UE4

Hopefully that is of any help for you!

[EDIT]

In the file ‘myproject/source/myproject.build.cs’ is a line like:

PublicDependencyModuleNames.AddRange(new string[] { "Core", "CoreUObject", "Engine", "InputCore" });

You shall try to add the name of the module there. I assume it is “AIModule”

[/EDIT]

Greetings Tim

Sorry for the LONG delay, been in new job, how do I add it to the external dependencies?

I have edited my answer, I hope that helps. I did not add an external module myself yet. Tell me if it worked!

Worked, thanks a lot :smiley: