Download

Where does the VR Template set 90 fps?

Does anyone know where the VR Template sets everything to 90 fps?

The game sticks at 90 fps. I have searched the Project settings and all the ini files I could find and I can’t find anywhere that says 90 fps as what the engine is trying to achieve. Also, the Framerate section of the project settings says its useing smooth frame rate with the min = 22 and max = 62. Any help is greatly apreciated.

The framerate is indeed capped at 90. Higher framerate = lower motion sickness. You don’t want to be running a VR experience below FPS. 90 FPS is what is required for Vive and Rift. If I understand correctly this is also the same rate (or integer multiple) at which the tracking systems update. So the framerate also needs to be synchronized with the tracking.
You will notice (with the Vive) that the framerate will drop from 90 to 45 if your game is unable to run at 90 FPS. You can try messing with the vsync setting to see if you can uncap the framerate from 90. It sort of depends on what headset you’re using. For the same project I can run my game at 60 fps on a PSVR device but I cannot run the vive at anything but 90 by default.

Good to know good to know. Thank you for the info :slight_smile:

I was asking becuase I am working on a game that heavily uses physics objects. Just spheres, but a bunch of them. Now depending on weather I have Smooth Framerate or Fixed Framerate the game runs very differently. On fixed framerate at 75-80 fps I can get all the way up to about 250 enemies on screen before game slow down starts to happen and when it does slow down, everything in the world slows down at a regular pace so I actualy can push all the way to 300 without it feeling weird. BUT! If I use Smooth Framerate the game runs super smooth at 90 fps but then takes a absolute nose dive at around 100 enemies down to about 10% speed. It is kind of a strange thing.

Thus my need to find where the actual settings are so I can try to tinker with things. Or if anything else you think might be a solution is always welcome :slight_smile:

The sudden drop is because you end up going straight from 90 fps to 45 fps. there is no intermediate framerate. You should profile and see if you are GPU bound or CPU bound when you get to the 100 enemies part. Then you can optimize accordingly.
https://docs.unrealengine.com/latest/INT/Engine/Performance/Overview/index.html :slight_smile:

Ahhhhhhhhhh haaaa. This makes sence. Thank you so very much.