Where can you activate GI?

How to activate “Show Flag Global Illumination”?
I can’t find this option anywhere!

I am having trouble to see the GI when using the Sun & Sky System.
my GI is not strong enough. Even when bumping about the GI Bounces to 100 - testing Brute Force and Final Gathering.
Nothing. The Shades stay pitch-black.

Is there a tutorial that shows step by step what you have to activate to actually have the GI activated?

My Project Settings have Ray Tracing on.
I am using DX12 - supported stdio drivers by Nvidia and RTX 2080
PostProcessVolume: Ray Tracing activated + increased bounces

When I boost the INDIRECT LIGHTING INTENSITY inside of the Global Illumination Rendering Features> I don’t see any boost in the GI.
Nothing happens, no effect at all.

I don’t understand what it means:
The show Flag Global Illumination must be enabled.

  • Where to enable?
  • How to enable this feature?
  • I can’t find any flag for GI???

I simple enabled GI in the PostProcess Volume.

Thanks a lot for any help!
appreciate it!

LOL! I was having the same problem with the “show flag Global Illumination must be enabled”. Before I got too frustrated, I simply tried changing settings, and didn’t notice much of an effect either. I think it is either in Project Settings, World Settings, or one of the default lights that’s in a newly created level. Try watching for it in the Introduction to Global Illumination learning videos, particularly the first video or first several videos if it’s not in there. I’m going to check too.…I-rBuyk&LPId=0

I was watching all of the Videos. But it is not even mentioned. I checked project settings, world settings, etc.
I can’t find that option.

Where is this thing hidden?:rolleyes:

Did you try the console command, r.RayTracing.Globalillumination 1? I believe even in the latest version GI is still an opt-in feature through the console, unlike shadows and AO.

Yeah, sorry I kinda misled you, remozseo. After I watched the tutorial video it is in, I now know it’s an opt-in via console command. Why is it saying in the Global Post Process that it’s a show flag? Doesn’t that mean it’s a check box in the details panel or in one of the main settings lists?

Well GI, as in global illumination, is not a thing you can just turn off and on based on a single setting but a process by which all elements with in the environment will give off and accept GI. You start by making everything in the environment movable so the lighting elements will give off dynamic lighting and the objects will accept dynamic lighting. Once things are movable then settings relating to GI should become functional.

OH and forgot under

No-Precomputed Lighting" checkbox in “World Setting”

Thanks for the info, @FrankieV. I wasn’t sure if all objects and lighting required being movable for GI to function properly. Based on the docs I’ve read, and tutorials, I had the impression it was not required for everything to be movable. Is it a ray tracing only feature? or can ray tracing be turned off for it?

@remozseo, it’s an opt-in feature via console, @rosegoldslugs is correct. Then in the engine, click the Show button in the viewport (upper right), scroll down to Lighting Components, and select Global Illumination if it’s not already.

Well try No-Precomputed Lighting" checkbox in “World Setting” first as this should give you a complete GI solution, or at the very least point out what needs to be changed as light baking will no longer occure

If using sky light along with a directional light I wquld also suggest turning off cast shadows on the sky light as it tends to shadow fight with other GI based lighting tthat also cast shadows.

“…turning off cast shadows on the skylight”

I bet that’ll get rid of the shadow lines I keep getting on geometry surfaces. It appears to be a mixing of the directional light and skylight in the 3rd person shooter template that I’ve barely done anything in yet. I was trying to fix the shadow lines problem from the start of the new project in it.

Thanks. Global illumination isn’t entirely ray tracing based, is it?

Well ray tracing in a game engine is a rather new thing but in most cases you need to configure the element to use or not use a feature. It’s more of a case of what Epic has decided to turn on or off by default. Just grab a light element and search the ray trace features. If it’s set to on the yes it will use RT but if off then no.

Basically ray tracing only improves shadow and light bounce behaviour and reflections if it’s not what you want you can turn it off as to a given element. the precomputed thing is just the big switch