When I use "Save all" it creates a new level


When I try to “save all” UE5 prompts a window where it asks to save a new level, even if I already have the level in a file.
When I use “Save current level” everything works fine.
I’ve never had this issue using a blueprint only project and now with a C++ project it always happens.

Any ideas on how to solve it?


This just started happening to me aswell.


started using this button works fine

i think it’s triggering the save as button instead of save all

1 Like

Try crtl shift s. Fixed what was happening to me

1 Like

crtl shift s still runs same problem for me

Somehow the issue today disappeared

Normaly if you save all, and havnt saved anything you will be prompt to save somewhere in folder.(you can pick)
Then even when you save/save all will automatically save over the current save.

Always use the save map to open your project that your working on.

I know save as (ithink thats what its called) will always prompt a place to save.

I normally crtl s (save) then crtl shift s (save all).

Yes, the behavior of the save all was the issue, I’ll keep the thread open since it looks like I am not the only one with the issue.

I did try with the shortcut, but it still prompted the same window… although I was using “save as” to save the level and then I was trying to use save all, and the only edits were on the saved map, it still asked me to create a new file.

I usually use blueprints projects and it never happened, on c++ projects I am experiencing issues just like this one or my new question…

Have you found a solution? The issue just vanished today on my end

yeah it has stopped for me as well. i think a reset fixed it for me. not sure that helps anyone but was my experience

Happened to me as well a few times in UE5. One time it wanted to generate seven new versions for the one level that was opened.


Just ran into this, too. To fix it and not lose work, I ran it as Standalone, which prompted a save. I was able to save everything, and when prompted to save a new level I hit cancel and re-started the engine. Problem gone.

1 Like

I use mostly blueprints, with a few C++ scripts and ran into this.

It seems to manifest most commonly when working with blueprints, at some point it just decided that the same level I’ve been editing needed to be saved to a new level.

The only way I “permanently” solved this was to exit the editor (while choosing NOT to save the level in question) and reopen Unreal.

Upon reopening, the level will be “Untitled” but a simple ctrl + S auto saved it to the correct name.

This feels very unsafe though TBH and try it at your own risk.

Run into the same problem when working with VR templet. Might because of the auto saves is conflicting? Anyone solved it yet?

For me, sometimes I was unable to save whitout saving as, sometime when I comeback in my project, some textures and assets were missing. Deleting all content in the autosave folder of the project, disable autosave in the editor preference and restarting my project from the first map solve my problems. Maybe just deleting the autosave content can do the trick ?

It started for me too once i started using mesh paint from that menu.

This has been happening to me a lot only in a recent new project I have been working in the last month or so, whenever I hit ‘Save All’. Sometimes when I would save it just kept asking me to save a new level over and over, the longest chain was like 20 new levels it asked me to save before it stopped. Sometimes it is 5 or 7 new levels. The only new thing I have been using in this project for the first time is datashith cad importer. It seems when I try to bring the Datasmith Scene asset(basically its just a group of all the meshes in the CAD file) into my level or into a sequencer, and then next time I save it does this. I have like 50 random saved levels, that I eventually widdle down and delete eventually once I know it is safe, but its really annoying.

Only way top fix it I have seen is save all the levels it asks, then restart the editor/proj, and now it will no longer do it. Until it pops up again a few days or hours later in the same project.

so i fixed by when u try exit program and save all pops up i unchecked where it said my levels name than auto so for my it was landscape_auto

1 Like

Same problem here

Hello, it finally seems that I have managed to solve it by deleting the SAVE folder. I hope it helps you.

reset the project?