When I try to use the new "Create Session" node, it fails

The output logs show: “Invalid or uninitialized OnlineSubsystem” and then on the next line, “Cannot map local player to unique net ID”

I’m using a fresh copy of the 3rd-person game template.

Here’s my blueprint setup. I have my character set up to call the HostSession event when I press a key.

I tried “Use LAN” both checked and unchecked.

So now it seems to work in PIE but not as a standalone or packaged game. Thoughts?

Hey Greg,

You’ll also need to add a default platform service entry to <YourProjectDir>/Config/DefaultEngine.ini (or you can use different values in the platform-specific inis if your project supports multiple platforms):


I recommend starting with Null, as above, since this will allow you to connect over a LAN and is the simplest to get working.

Hey Ryan,

I already had that in there, but it didn’t fix it. Are there any other ini’s I should worry about?

I added what you said there to BaseEngine.ini and now it seems to work when run as “game,” but not when packaged. I’m really confused.

You sure you did DefaultEngine.ini?

Yes, MyProjectFolder\Config\DefaultEngine.ini. I’ve also tried BaseEngine.ini and adding my own Config\DefaultEngine.ini in the packaged game. Still no dice.

I’m having trouble reproducing this failure. I’m using UE 4.6.1, create a new project with the Blueprint 3rd person template, add a CreateSession node called from a key event, and add DefaultPlatformService=Null to Config/DefaultEngine.ini. Package project for Windows 64-bit, run the game from the package, trigger session creation, and it succeeds.

Which engine version are you using? Is it a custom build from the GitHub code? Also, are you getting the same error message in the log from the packaged build (“Invalid or uninitialized OnlineSubsystem”)?

Hey Ryan,

I just solved it by adding the OnlineSubsystemNull dependency in my Build.cs file as detailed here: 4.6 Preview and Create Session - Multiplayer & Networking - Unreal Engine Forums

Both my actual project and my 3rd person template seem to be working now, thanks!

Ah, glad to hear it - I apologize for not mentioning that earlier, I should have asked if you were using the Blueprint 3rd person template or the C++ 3rd person template!

It was my fault too, I wasn’t clear about whether I was using a BP or C++ project.

This works for me ! Thx bro !

nah it’s my fault, I should’ve read this thread sooner and informed both of you ;D