When I package UE4 multiplayer, I can't set up a server

excuse me.
I’m a beginner studying multiplayer game production.
I am using the “Main Menu” of the data downloaded from this URL.

When I check this data, PIE sets up the server and succeeds in connecting to the server on another screen, but when it is packaged, it does not work and the level does not move.

I get the following error when I quit the PIE editor. What is the cause?

※I’m using Google Translate.

I got the exact same issue that was driving me totally crazy!! And the solution was super simple: I just forgot to package the lobby level (well, I actually did that, but I moved the level into another folder and the packaging settings were not updating.)

What you have to do:

  1. Click on “Package Settings” in the dropdown menu that you see when you try to actually package the game.
  2. Scroll down and expand every section of the settings until you see “List of Maps to include in a packaged build”
  3. Add a new element to the array and click the little dots to browse to your maps
  4. Finished result should look like this:

At least this was helping me…

私は全く同じ問題で完全に気が狂いそうでした! そして、解決策は超簡単でした。ロビーレベルをパッケージングするのを忘れていたのです(まあ、実際にはしたのですが、レベルを別のフォルダに移動したため、パッケージングの設定が更新されなかったのです)。


  1. ゲームを実際にパッケージしようとしたときに表示されるドロップダウンメニューから「パッケージ設定」をクリックします。
  2. 下へスクロールして、パッケージビルドに含めるマップのリストが表示されるまで、設定の各セクションを展開します。
  3. 配列に新しい要素を追加し、小さな点をクリックしてマップをブラウズする
  4. 完成はこのようになります。



thank you!
I tried the method you taught me and it worked!

Thank you for your very nice advice.

1 Like