When I compile c++ Code it does not apply changes

Title says everything

Some times it helps to re open Visual studio or compile it in UE editor this alwasy works.
Hope this helps : )

I did nearly everything only close and open again works

Did ue crashed then sometimes the “conection” between Visual studio and UE breaks.

No It does not

Sorry but I don’t know the awnser to your problem : (

My OS is windows 10 but I have windwos8.1 sdk could it cause that problem ?

I have windows 7 so it is maybe something else

do you compile using “compile” button inside the Engine, or manually by visual studio?

both of them

on editor case, what does the output log writes? you can access the log in Window->Dev* tools ->Output Log

Candidate modules for hot reload:
Launching UnrealBuildTool… [C:/Program Files/Epic Games/UE_4.16/Engine/Binaries/DotNET/UnrealBuildTool.exe StelBlotPreAlpha -ModuleWithSuffix StelBlotPreAlpha 7859 Win64 Development -editorrecompile -canskiplink “C:/Users/FatihMelih/OneDrive/Belgeler/Unreal Projects/StelBlotPreAlpha/StelBlotPreAlpha.uproject” ]
Warning: Starting HotReload took 0.0s.
CompilerResultsLog: New page: Compilation - Jul 1, 2017, 11:33:41 PM
CompilerResultsLog: Info Compiling game modules for hot reload
CompilerResultsLog: Info Parsing headers for StelBlotPreAlphaEditor
CompilerResultsLog: Info Running UnrealHeaderTool “C:\Users\FatihMelih\OneDrive\Belgeler\Unreal Projects\StelBlotPreAlpha\StelBlotPreAlpha.uproject” “C:\Users\FatihMelih\OneDrive\Belgeler\Unreal Projects\StelBlotPreAlpha\Intermediate\Build\Win64\StelBlotPreAlphaEditor\Development\StelBlotPreAlphaEditor.uhtmanifest” -LogCmds=“loginit warning, logexit warnin
g, logdatabase error” -Unattended -WarningsAsErrors -installed
CompilerResultsLog: Info Reflection code generated for StelBlotPreAlphaEditor in 11,2378029 seconds
CompilerResultsLog: Info Performing 3 actions (2 in parallel)
CompilerResultsLog: Info StelBlotPreAlphaProjectile.cpp
CompilerResultsLog: Info [2/3] Link UE4Editor-StelBlotPreAlpha-7859.dll
CompilerResultsLog: Info [3/3] Link UE4Editor-StelBlotPreAlpha-7859.lib
CompilerResultsLog: Info C:\Users\FatihMelih\OneDrive\Belgeler\Unreal Projects\StelBlotPreAlpha\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-StelBlotPreAlpha-7859.lib kitapl??? ve C:\Users\FatihMelih\OneDrive\Belgeler\Unreal Projects\StelBlotPreAlpha\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-StelBlotPreAlpha-7859.exp nesnesi olu

CompilerResultsLog: Info C:\Users\FatihMelih\OneDrive\Belgeler\Unreal Projects\StelBlotPreAlpha\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-StelBlotPreAlpha-7859.suppressed.lib kitapl??? ve C:\Users\FatihMelih\OneDrive\Belgeler\Unreal Projects\StelBlotPreAlpha\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-StelBlotPreAlpha-7859.supp
ressed.exp nesnesi olu?
CompilerResultsLog: Info Total build time: 91,80 seconds (Local executor: 73,95 seconds)
LogMainFrame: MainFrame: Module compiling took 92.142 seconds
LogHotReload: Re-instancing StelBlotPreAlphaProjectile after hot-reload.
LogContentBrowser: Native class hierarchy updated for ‘StelBlotPreAlpha’ in 0.0013 seconds. Added 4 classes and 2 folders.
Display: HotReload successful (1 functions remapped 0 scriptstructs remapped)
LogContentBrowser: Native class hierarchy populated in 0.0084 seconds. Added 2335 classes and 497 folders.
Display: HotReload took 92.4s.

I more Thing.I tried to edit the projectile class like should bounce could that caused problem ?

I solved it by right clicking on Class View → my project → clean, then I recompiled on visual studio and then also from ue4

1 Like