When deforming the terrain foliage won't apply to it


When I deform my terrain the foliage I placed the last time I opened the UE won’t move along with it. Anyway it works if I delete and repaint. Is this some kind of bug? Is there a button to reapply foliage to terrain or do I really have to delete it just to make some changes to the landscape?

Thanks in advance!

Hi RobotK,

What version of the editor are you currently using? Additionally, you should be able to use the “Reapply” feature in the foliage mode to repaint any foliage that doesn’t move with the landscape.

I’m using 4.6.1. The Reapply feature won’t help. That’s the point. All foliage i painted will simply stay where it is although i can reapply scale and stuff like that. If i paint new foliage it will move along when deforming the landscape.

Are you changing the landscape in editor or are you importing/reimporting using heightmaps from a program such as world machine?

I created the landscape with the UE4 landscape editor.

I still need to delete my foliage and repaint it to apply it to my edited lanscape. After i painted new foliage i can deform my terrain as much as I like but once i save and reopen the engine i have to delete it again. That’s quite circumstantial…

Hi RobotK,

I just want to make sure I understand what you are saying. Are these the steps to reproduce this error?

  1. Create Landscape
  2. Apply foliage to terrain
  3. Deform terrain (foliage does not move, reapply does not work)
  4. Delete/repaint foliage
  5. Deform terrain (foliage appears to move)
  6. Save and Close editor
  7. Reopen editor

At this point the foliage will not conform to landscape and needs to be deleted/reapplied? Please let me know if I got any of this wrong as I have several users reporting this bug, but I haven’t been able to reproduce it on my end and I’d certainly like to figure out what is going on so we can get this nasty bug fixed!


I know this was confusing (As you might have guessed English is not my mother tongue)

  1. Create landscape

  2. Deform the terrain

  3. Paint foliage

  4. Deform the terrain → Everything works as it should and the foliage moves along without the need to reapply anything.

  5. Save and close the engine → Restart the engine

  6. Deform the terrain again but well the foliage stays where it is… When using the reapply tool the foliage still doesn’t move…

  7. Delete foliage

  8. Repaint foliage

  9. Deform the terrain and the foliage will once again move along as long as I don’t restart the engine.

Thx for trying to solve this issue. I’m relatively new to UE so I’m not really used to it yet. :smiley:

Are you using speedtree foliage, an object in the editor already, or custom static meshes by chance? I attempted to reproduce this bug but still cannot seem to reproduce the error. After restarting the editor the foliage moves with the landscape as intended. Additionally can you show me a screenshot of your painting settings for your foliage?

I’m using my own meshes i created with blender.
I guess I should also mention that I have a lot of foliage positioned in my landscape. (Another problem btw: When I try to move one single tree it lags quite a lot and I have to wait quite some time before I can see any effect)
Could the amount of foliage be the reason for this?


Try pressing “align to normal” then follow the same steps you listed above. Does the foliage still refuse to reapply?

I used align to normal for grass foliage and it still stuck under the terrain. Only trees were painted without align to normal. I tried it again and it didn’t work.

If you want to I could show you my scene via teamviewer or skype. That might help.

I just tested placing foliage in a test project and i’m also not able to reconstruct this error. As you mentioned there are more people having the same problem so at least I’m not alone.

I will keep having a look. It’s interesting because one of my team was able to reproduce it, until he attempted to repro it after we discussed this as well as other reports about the bug. At that point he attempted in the project he had initially seen the problem on but was unable to repro it again. I’ll see if I can find the common link between these and see what we can do to fix and/or provide a reasonable workflow for foliage in this case.

Thank you. At this stage of my project I can deal with deleting and replacing. I hope you’ll be able to fix it soon. :slight_smile:
I started my project in november last year. Maybe an update caused this error.

Hi RobotK,

I haven’t been able to reproduce this on my end, but I went ahead and entered two bug reports (one for the foliage not automatically adjusting to the landscape, and one for the reapply tool) to be assessed by the development staff. These are UE-8684 and UE-8687, respectively.

Hi RobotK,

I understand the main part of the issue is that after painting some foliage, closing the editor and returning to the landscape, the foliage is no longer attached to the landscape and doesn’t move when painted. We’re not able to reproduce this part of the bug in 4.7 and I we believe this should be fixed in 4.7.

As for the foliage you currently have in this situation, selecting it with the Lasso tool and pressing the END key on your keyboard should snap it back to the landscape and restore the reference.


Thx for your answer .

I tried to use the lasso tool but it won’t work. When I left click, a yellow line starts to move uncontrollable and I can’t select anything. When using the select tool, I finally can select my foliage. Anyway using the end key won’t work with all my trees. I attached pic where you can see that my lasso tool won’t work properly.

This tree was selected with the select tool and using the end key didn’t work for it. On the other hand one of my spruces snapped back on the terrain. I also tested the lasso tool in a new project and it worked there. I hope my project isn’t broken or sth. I put a lot of effort into it.

Hi RobotK, sorry about the selection problem with the yellow line. That’s a separate bug that we recently fixed for 4.7. It happens only on meshes with World Position Offset in their material so you could temporarily disable that in the material if that helps.