Wheels of vehicles have wierd motion blur

Has anyone seen a vehicle with motion blur on from side ?
Its wheels show weird motion blur until blur amount is set to very low.

Is there any way to exclude or decrease the effect of motion blur on wheels ?

Vehicles by default don’t have per-bone motion blur enabled – this is probably your issue. Go into the skeletal mesh for the vehicle and there should be an option for turning on per-bone motion blur.

I have the same problem. Wheels on my car bluring too much, which causing visual artifacts. When I decrease overall motion blur amount, they’re looking just fine, but it’s a very low amout of motion blur for everything else. Per-bone motion blur is on by default, and turning it off seems to have no affect.
As asked before, is there a way to decrease amount of motion blur per object?

i have seem problem !!! it 's really ugly

If found the solution in this old entry in the answerhub. As it seems, when you create a new project motion blur is enabled in the project settings by standard. Just go to the project settings and look there in the rendering section for motion blur.
At least that worked for us! :wink:

1 Like

There is also a bit of info in this thread.

I don’t know if you ever found a solution to this but this is what we found works to solve the problem.

In our dcc tool we created two sets of wheel bones placed at the pivot for the wheels. One set is the PhysX simulated wheels while the other set drive the visual wheel mesh primitives. During the vehicle setup assign the PhysX simulated bones to the vehicle movement component under wheel setups. Inside the vehicle animation blueprint we first call the Wheel Handler node to update the PhysX simulated bones then copy the rotation and translation to the visual bones. As strange as it seems this allows you to perform correct motion blur on the wheels.

In the camera for the vehicle we found these motion blur settings to work well for our setups.

Amount: 0.5
Max size: 0.75
Per Object Size: 0.5

These may need to adjusted for your camera and mesh setup.

The double wishbone suspension tutorial goes into the details of how to perform the copies from the PhysX simulated bones to the visual bones.

Here is a pic of our animation blueprint. It includes the double wishbone setup. the first four CopyBone nodes copy the data from the PhysX wheel to the corresponding Visual Wheel. Note: The steering of the front wheels is part of the PhysX simulation.

Hope this helps others trying to implement wheeled vehicles and runs into the motion blur problem.

1 Like

I’m trying to reproduce your setup with double bones but there it still as much of ugly blur effect as when there is a single bone. Can you share your project ? Thanks.

I’m sorry but I no longer have an archive of this project. I will attempt to reproduce the project tomorrow as time permits.

And to not be misleading, the double wishbone suspension has nothing to do with the motion blur problem. The copying of the PhysX bone to the visual bones corrects the motion blur issue. The double wishbone setup is nothing more than a visual appealing addition to the suspension system.

It would be very nice of you to upload such a project, thank you ! I understand that the suspension bones have nothing to do with the blur problem. I only tried to reproduce the Copy Bone setup on the left part. If you could also upload your 3d file it to see the rigging it would also help a lot. For my vehcile I followed this tutorial to properly rig my mesh : How to Rig and Setup a Custom Vehicle in Unreal Engine 4 - YouTube

Greetings @MauiSnowStudios

This is an excellent video on the topic. Thank you for posting. I’m sure it will be helpful to people who search this issue in future!

The link of the video is broken!! HELP PLEASE!!!

I found the fix in this post…Thanks For all