What's the "proper" way to use reflection captures with lighting scenarios on mobile (quest)?

I have the following situation:

  1. One (1) persistent level - contains most of the geometry & a skylight (to avoid “multiple skylights” warnings)
  2. Two (2) light scenarios sublevels - they contain their respective light sources and teh meshes that represent them, (along with a couple of other non-related meshes).

When it comes to reflections, I tried a couple of setups:

  • all captures in the persistent level = no reflections appear at all, whichever lighting scenario is (un)loaded

  • Captures are placed in each of the lighting scenarios = reflections work only with the first scenario that gets displayed, while the second one reflects total blackness.

Take note: when played in the editor (VR preview) it always works, whichever way I set it up. The described behaviour happens only when the app is deployed to Quest.
Also, when deployed on Quest and using regular level streaming (instead of lighting scenarios) - everything works as expected. The tiny hitch, half a second-ish that it takes to load a streaming level as opposed to switching a lighting scenario is really not worth the hassle.

Is this a bug, a feature or a simple case of n00bness?

I Think I found the solution for captures:
You need to make Scenario Level ACTIVE in level browser then do Build Reflection Captures, and at the end Save that scenario level.
After that idiotic procedure ( scenario by scenario ) this captures works.
Epic has a bunch of strange surprises for everyone and always :slight_smile:

1 Like

I had a similar problem (worked fine in desktop, not on Quest).
I’m having different predefined scenario’s (different mesh locations, not lights), set as blueprint sublevels that I load/unload depending on the scenario. So I want to use lightning scenario’s to avoid black spots (from their shadows - static lightning) when meshes are at a different location in the (same) level.
But when enabling lightning scenario’s, my reflective materials were always black (because my reflection cubes were in a general lightning level). I have now added reflections cubes inside all sublevels that have a lightning scenario and then build + save them one by one which, as you mentioned. That works, so thanks for that.
It’s a pain though because I have to duplicate all the reflections for each sublevel so it gets build properly, even though the reflections for each sublevel are at the same location.

Ups, I’m facing this exact issue. But no matter what I try, moving reflection captures across sublevels being light scenarios and such, marking ACTIVE (double click in level browser I pressume), building and then saving (I’m not able to save until I move a bit the sphere, then build reflection…) Whenever I use a light switch that (un)loads two lighting scenarios (DAY and NIGHT), reflection probes stop working. Fun fact. It only works in the default scenario until I switch back and forth. I will break the reflections for ever… Any advice? Thanks!

EDIT: Ok, three days pulling my hair off, then I discovered that it was my fault. Just my BP judo is darn weak and I load first, then unload the light scenario. IT NEEDS TO BE THE OPOSITE. It breaks the system as clearly stated in feature limitations of lightning scenarios. See the bullet regarding reflection probes.