What the hell?

This Branch is cursed, It never sets to true for some reason. This is the hellhole, we reached the bedrock of BP coding where commands refuse to do what we say.

this is the widget (also branch is also tick event for checking conditions of booleans every 2 sec (delay))
things I tried:
1.) adding 6 sec delay before remove from parent.
2.) trying tochange variable of an actor and get referance to timer out outside of widget.
3.) casting to player character and get referance variable from it.
4.) totally redoing order.
5.) setting boolean in front of white path since maybe It doesn’t update variable due to theres no set command.
6.) keeping my sanity.


7 hour ago?

widge a variable so is it being set in the shown BP? When you call Add to viewport node that target needs saved with set widge?

First , don’t use delay in event tick for this purpose. Better to set timer (by custom event for example) at event begin play, that loops every 1 second (set looping checkbox). Then drag execute line from your custom event to whatever you want that loop to do.
Second, once you remove the widget from parent, it no longer exists and neither do the variables in it (like Timer_out or Saniye). That means if you call on this variables from another blueprint - it wont read them because the widget is invalid (you removed the widget).

I’ll try this one

I also tried that for both characters and other actor that is exist on my map. instead of changing widget’s timer out I set a variable for changing that actor’s boolean and try to set up just like I said here

I just observed no matter what boolean I place It’s always hitting false. Yea solved by mimic timer of widget seperatly from bool
Side effects: no longer able to skip timer
Bools are evil!
Case closed.

but the Widget variable that it contains? when you create the widget you don’t make a set. Soesn’t it give you errors?

nope. that’s why this **** is possessed. Case closed final thought bools are evil. We banished that monstrucity.

You hate 1s and 0s? Wait till you learn about other numbers… :wink:

Substitute Booleans with 0 & 1 Integers - if your code still does not work, perhaps its the way it’s scripted :expressionless:

I see Tick + Delay + DoOnce - that’s a red flag. I’d blame logic / flow rather than the venerable variable. I’d generally blame myself before blaming it on the engine. And, as it turns out, I’m right too many times. The engine has bugs, sure, but this seems like a plain user error.

Consider stepping through the code. Print string, watch values, add breakpoints - Debug.

There’s also the Rubber duck debugging - Wikipedia. It saves lives.

1 Like

An enormous red flag indeed. All it needs is some randomness added into the mix and you got the perfect storm.

I’m actually fully awere Of that because this spawner is temperary. It’s gonna be destroyed few seconds after game starts and replaced with another. And while wandering around error messages I findout I might should’ve used is valid command. That’s might be the case. I’m not blaming engine, I’M just overracting the post. I know something is wrong about somewhere.

1 Like