Download

What the heck is going on?

For some reason it won’t let me download the Engine! At teh top left is says “No Engine Installed” but then I click the subscribe button and I enter all my info I hit “Submit” and it just brings me the log in payment thing again. WTH is going on?

Is this the first time you’ve downloaded?

Have you downloaded previous versions?

If you have downloaded previous versions, have you stopped your sub?

If you have, you can’t download newer versions unless you re-sub (It should still work once you’ve paid up for a months access until that month is up though)

Yes, it’s my first time downloading it. I have not downloaded any previous versions either.

This may sound silly but, are you sure you’ve paid for it?

If you are looking at the main UE page, and hit sign in in the top right, then enter your info and hit sign in again. It should on that page (your Dashboard), right dead in the center say “YOUR PLAN IS CURRENTLY: (ACTIVE)”, on the right from there are direct links to the msi or dmg depending on your OS. I obviously won’t post the links here (I assume they wouldn’t work anyway, but for obvious reasons I won’t post them) but you should see a direct link to for example for windows, a UE installer MSI file on the epicgames server. Do you see that? Do you see the “your plan is currently active?” if from there you click on the download and get sent to the payment screen, but it says y our plan is active, I would contact support

Start the launcher with admin rights.

Hi Jonathan87,

Sorry to hear that you are experiencing this issue. We have had three other users report it previously, and each was able to resolve it in a different way.

https://answers.unrealengine.com/questions/64344/installing-issue-explanation.html
Solution: Run the Launcher as admin

https://answers.unrealengine.com/questions/60024/unreal-engine-will-not-install.html
Solution: User was behind a proxy, had to enable an exception to allow the download

https://answers.unrealengine.com/questions/59901/launcher-cant-install-engine.html
Solution: The issue went away after a reinstall.

Please let us know if any of this helps you or not.

Thanks

Still no go! I have uninstalled and re installed several times and tried the admin & proxy thing. Although when I run the Launcher I click “Library” and click 4.2.0 Subscribe it brings me to the payment page again. And when I log in from the site I click the dashboard and it gives me this

PLAN DETAILS:
WHAT YOU GET WHEN YOU SUBSCRIBE:
Unreal Engine 4 features and tools
Full C++ source code access via GitHub
Official documentation and tutorials
Forums, AnswerHub and wiki access
Ongoing, regular updates
The subscription price is per seat. You are free to cancel anytime.

GET UNREAL - $19/MO + 5%

Maybe it’s a problem with my credit card? I have tried several times with my card and it still shows nothing has been taken off my card. perhaps or does it take time for the transaction to go through? or is it instant?

Let Me Know!

@Jonathan, to me it sounds like the purchase didn’t go through.

Scroll up and read my post, if your dashboard doesn’t say “subscription status: ACTIVE” then it’s a payment problem and you should use the contact link I provided earlier.

@Jonathan87,

As recommended by the others, please contact [EMAIL=“accounts@unrealengine.com”]accounts@unrealengine.com so they can investigate to determine the status of your account.

If they cannot identify any issue but the problem is still ongoing, then I ask that you please submit a report on the UE4 AnswerHub: https://answers.unrealengine.com/index.html - in the Installation & Setup section. We can continue to troubleshoot your issue from there.

Thank you.