Download

What should I do to disable all dynamic lighting in a level?

I want to go with Baked Lighting only. What do I do to disable all dynamic lighting?
Should I do something in project settings or somewhere else.

Or do I need to go through the entire level light by light and also all actors that can move and cast a shadow, and change the settings on each object?

Dynamic lighting is controlled via your individual lighting actors. Unless you specifically switched them to dynamic, you don’t need to do anything. By default UE4 uses the stationary mode.

If your trying to maximize efficiency just make sure each point light is set to Static (it defaults to Stationary) and uncheck the Dynamic Shadows checkbox on each light.

Thanks guys. They were all set to cast dynamic shadows. Hopefully this cleans things up.

I changed all my lights to Static.

When I uncheck the Dynamic Shadows Checkbox on all. I pretty much stop getting any shadows at all.
I get lighting variations based on surface angles but no shadows.
And it looks pretty bad.

I am looking at epic’s example from the content examples Lighting V2.1

According to Epic’s documentation,
they say that the settings in the example are to get Baked Lighthing Only.
In the settings for that example. The light was set to static.
But cast dynamic shadows is set to true for both the mesh and the point light.
So I am a little confused as to what the right settings are.
Do I need to uncheck that box?

Screenshots are attached
StaticMeshSettings.jpgPointLightSettings.jpg

Dynamic shadows only activate with moveable lights. You won’t dynamic shadows from static, you’ll need to bake your shadows through the light building process.

Make sure the objects on your map which are not moveable are set as Static as well, or else they will not receive lightmaps. You’d generally do that to as much as you can, leave stuff like chests or opening doors as Stationary. For characters though you will lose all dynamic shadows. You have two options there, either have some select shadows be left as dynamic shadow casters or you could try using capsule shadows.

You can get capsule shadows from global illumination for indoor scenes and they are cheaper than normal dynamic shadows. They don’t look quite as good and require you to create a capsule for them, but for VR I found this was the best route. It allowed me to bake all the lighting on my map and since I was using all indoor maps (currently on a dungeon crawler) I had no sunlight to cast dynamic shadows, but this route allowed me to still have them and was cheaper. So something to consider.