What setting controls the resolution of GPU Lightmass baked volumetric lightshafts?

My aim is to have baked lighting with high-resolution light shafts.

Scene setup:

  • Using shadow maps (not VSM) and Nanite
  • Stationary directional light with area shadows enabled
  • Volumetric fog enabled in exponential fog

Before baking, the resolution of the lightshafts is controlled by r.Shadow.MaxCSMResolutionr.Shadow.MaxCSMResolution`. Setting this to e.g. 4K, I can get super crisp lightshafts:

However, as soon as I hit “Start Building Lighting” in GPU Lightmass panel, the resolution of the lighshafts decreases considerably, leading to extremely low-resolution lightshafts:

(please ignore the rest of the scene, I took the screenshot early on in the baking process, but the light shaft resolution stays the same after the bake is finished)

I have tried every single setting I could think of, nothing seems to affect. It’s weird that baked lighting is even somewhat correctly affecting here in the first place to be honest, CPU lightmass can only use the volumetric lightmap for affecting volumetric fog, but GPU Lightmass seems to have some sort of a feature here that behaves differently and better, if only I could tweak the resolution.

I almost assume that there must be some sort of a hardcoded value in GPU lightmass source at this point, but if anyone can point me in a direction here that would be greatly appreciated!

I am also open to other solutions, such as using a static light with VSM for the lightshafts, but I have not been able to find any configuration that would give baked shadows with crisp lightshafts. Weird.

Do you mind sharing your gpu lightmass build settings?