Download

What seems to be the issue with this LIGHTING UNWRAPPING ?

Hi guys. I am trying to get lighting PERFECT on this 3D object and can’t manage to. What seems to be the problem?

I am using extremely high settings and still get blotches and weird shadows.

SETTINGS

Lighting Scale 0.25
Bounces 50
Quality 10
Smoothness 0.6
Compress Lightmaps unchecked

Lightmap resolution for each individual object is 1024.
Mapping was done using blender. I deleted some duplicate vertices in order to be able to loop seams.

Check the file here: https://www.dropbox.com/s/j2rsm5fhstc5k8n/desk_BLENDER_2.fbx?dl=0

Check the screenshots in the attachments.

You seem to have bad split normals.

0c9fccf67014a26581312cda28ac89ed9c38f448.png

Select all the faces on the bad meshes and choose to clear the custom split normals

3e2e86d758316c7f824c5f11d944cbbde9fdef07.png

41456a46bf027d036bf4476c1890af783102f4a0.png

Finally AM149_set14_09.003 appears to have multiple copies of the mesh data in edit mode select a face, select linked, delete, repeat :slight_smile:

ef0875e369f0c9fcfb4741a546d5a3f7de200a84.png

Hello! Nice to see such a quick feedback! Thank you Anadin! Fixed the overlapping geometry. (stupid mistake) Cleared the custom split normal data on all objects individually. (every time in edit mode - dont know if thats really necessary but still…) Worked like a charm for some parts of the geometry but still getting blotches and weird shadows for other parts.
Whats the problem with these guys? should i play around with the Auto Smooth Angle? (it is at 30 by default)

Might there be any light setting that i should play with in UE4? Right now I am using similar settings as the ones showed before except Compress Lightmaps which i left checked.

1.PNG

2.PNG

Check new model here: https://www.dropbox.com/s/5a9qqap5mrl9eld/desk_BLENDER_NOMRALS_3.fbx?dl=0

BIG THANKS !

No prob. For these ones I think the model looks good. Can you double check in your static mesh settings which UV maps the light mapping is set to? I have seen them sometimes swap.

I checked that, everything seems ok here.

2.JPG

And UV channel 1 for this object

3.JPG

Do you have a light mass importance volume in your scene? And make sure it’s set to production. Otherwise I’m not seeing anything obvious that would be causing issues.

Taking a look… will get back if I figure something out :slight_smile:

@ZacD even with LM Importance Volume there is still wierdness there is overlaps in the UV’s in LM preview mode too - suspecting some hidden geo…

AutoScreenshot.png

OK I havn’t modifed GEO and reimported into UE4 but…

couple more comments

Screenshot 2016-12-04 18.24.26.png

You have varying densities of geo on the legs, probably don’t need the higher density versions

2f037ed6d6c83646abac2b18fbccda39e3f4798c.png

Blender’s slightly poor depth drawing shows up an issue here, the geo is VERY close to the leg. You may just be getting bleed from too thin geo that is too close to other geo.

could you perhaps fix the positioning a bit and maybe make the legs a bit thicker?

Any surface that overlaps another surface will have some bleeding because it’s unlikely that the pixels of the lightmap will line up with where the shadow needs to be rendered so some shadow will be visible.

Will try that right now, see how that works and keep you posted with the new model and results.

Keep in mind that I deleted some double vertices in Blender in order to be able to loop the seams for the unwrapping. Might this affect the geometry somehow? (i used lowest merge distance)

Thank you!