what might be causing these really weird shadows..

before I build the lighting… i LOVE the look…

but after…


aeb8559017993d2d7ffd373788e9fffcc519c9bb.jpeg

I can and will remap my assets… but I am pretty sure the UV mapping is pretty straight forward already with most of my stuff… mostly used “automatic” mapping in maya…

I have edited the realistic lighting project and resaved it as my own level to borrow the already awesome lighting… I wanted the same lighting leaking in through my bay window…

but then I get this when rebuilding ^

any advice is always appreciated.

EDIT … Maybe… its from the pleated curtains that used to be in the scene ?

Increase the lightmap resolution of the floor mesh.

rebuilding now… but even if the shadows improve… whats with the dark dark shadows as opposed to the light filled ones I get while “dynamic” ?

To make your shadows brigher you will have to add a skylight (disable “cast shadows” in the properties of it)

Do you have second UV channel on meshes?

Few rules of thumb I learned with a hard way

  1. increasing lightmap resolution is not solution. It just masks the problem
  2. Don’t relay on automatic unwrapping. Always unwrap manually, take in consideration shell padding
  3. Automatic uv generation in Engine sometimes makes magics and sometimes just messes us mesh
  4. When unwrapping faces with face different directions should be spitted in different shells
  5. Always set light quality on production while testing shadows and lighting in general
1 Like

Most likely your lightmap UV’s are really bad, especially if you used an automatic method. And since it’s a large room the resolution is probably too low. You may need to separate out some stuff so that it can use more lightmaps instead of just increasing the resolution.

here’s the latest.

as suggested, I added a skylight… now I get distributed lighting… :slight_smile:

but… even after remapping my UV’s… I get crappy boxes on my walls… and the error checker still seems to think UV’s are overlapping.

next, I’ll try creating a separate UV channel for lighting I guess… :frowning:

I wonder. might it now be due to not remapping the window/panes the light shines through ?

Before you do this take a look at this link: http://www.worldofleveldesign.com/categories/udk/udk-lightmaps-01-basics-and-important-principles-for-creating-using-lightmaps.php -> explains everything about lightmaps :slight_smile:

If you didn’t have lightmap UV’s before and then added them then you need to set it to use the right UV channel, it doesn’t change automatically.

so if my “asset”… consists of multiple sections of walls, doors etc… and I import them all merged as a group… with separate textures for each piece. wallpaper, woodframe, glass, metal doorknobs etc…

how do I, or can I, edit each piece separately and set the lighting UV channel ?

wouldnt double clicking my merged asset group simply open up one window with one universal setting ?

If they are a single static mesh in the content browser then the entire thing only gets one lightmap. It’s not per material, it’s per static mesh.
If you only have one UV channel and then generate a new lightmap UV channel, then you need to open the static mesh in the content browser and set the lightmap UV setting to the channel that has your lightmap UV’s, since it won’t change it automatically after generating lightmap UV’s.

UG.!

so even though I went through the time consuming light-mapping process for each piece in my door and wall…
65818fb691b4ed06aa2a103587a7ed26722398d5.jpeg

if I export it all in one go as a single mesh… the engine only sees one lightmap and does this to it ?

and the more pieces you put into that export… the worse UV overlap gets… ?
00e3d27d870934189d77331e6b8dc654d25af2c2.jpeg

I am soooo tempted to somehow override the need to even BUILD, lighting !

I LIKE dynamic lighting !

I wonder. if this is the case… can there be any way to create a mel script to export each piece in a .mb file as its own ___.fbx file into a dedicated folder for that level/ mb ?

then once in unreal…import the entire folder then run the “same” script. placing each piece at its world position, duplicate it… and replace it with the next one from the folder ? doing the same for all the items in the folder…

NOW… will UCX_ proxies also cause overlapping lightmap UV issues if I have several meshes being used to give ONE mesh physics ?

When you import to UE4 there’s an option for Combine Meshes, if you turn that off it will separate out each object that you exported. As long as they are separate objects in Maya they will end up as separate objects in the content browser.

If the naming is correct, I think your collision should work correctly this way as well.
In 3ds Max there’s a tool in the Content section of the forum that can reposition each object to the origin>export each object to its own FBX>and then move the objects back to where they were–along with the option to copy the positions of the objects so that you can paste the positions into UE4 so that you don’t have to place them back by hand.
The alternative if you’re trying to keep things as easy as possible would be to just export your objects like you have them. It won’t be quite as efficient performance-wise because you might have multiple exports of the same object, but everything would be positioned exactly where you have it in Maya.