Download

What is wrong with UE4 Static Lighting ?

Am I making something wrong or what is wrong with this simplest of simplest scene lighting ?

http://s23.postimg.org/jjc3i7b6x/image.png

The artifact is not disappearing until I set Static Level Lighting Scale 0.1

http://s23.postimg.org/b2cl7a6i1/image.png

I used one sided plane static meshes. It is not BSP.

Can you try and re-upload your images? They aren’t showing up right now. :slight_smile:

Hi,

  • Give the meshes some thickness. Dont work with planes.
    and if you work with static lighting, also:
    -Add a lightmass importance volume.
  • Make sure you have proper lightmap UVs.

That should help :slight_smile:

Cheers,
Klaus

Hi,

This post on the forums should cover just about any area of concern with this: https://forums.unrealengine.com/showthread.php?46269-Modular-Asset-Lighting-Problem

Adjusting the static lighting scale isn’t probably the best solution though as this will increase light build times the more your scene grows and is not only for the single objects but all objects.

The main things to check are that you’ve built your lightmaps with the hard edges snapping the grid for your target lightmap resolution (covered in the post above) and why this is important.

Adjusting the world settings you can help reduce this as well by adjusting the Indirect lighting smoothness to .6 and the Indirect lighting quality to 2. I would start adjusting these settings before ever touching the lighting scale option. Usually these settings will help as a starting point.

Feel free to ask any questions as they come along. :slight_smile:

Tim

Thanks for reply.
I tried lighting smoothness to .6 and the Indirect lighting quality to 2 and even 4 but didnt work.
One thing I am sure that it is not about lightmap padding.
It is about indirect lighting. If I set indirect intensity 0.0 on Post-Processing volume, it totally fully disappears.
Once more, the reason of problem is within indirect lighting.
I dont even remember I saw this artifact on previous versions. It could be after 4.4 or 4.5.
It is not our mistake or something. It is clearly a problem within engine.

It’s a smoothing issue, but ultimately you shouldn’t be using such simple geometry in pieces, build the entire surface as a single object.

@Tim Hobson:

>The main things to check are that you’ve built your lightmaps with the hard edges snapping the grid for your target lightmap resolution (covered in the post above) and why this is important.

I have similar problems.

In the post above you wrote that the grid should be 1/128 but on answerhub you wrote that it should be 1 / (128 - 2) for 128 resolution. Which one is correct?

Which padding should I use between UV shells? And how much padding between UV and the border?

Personally I still use 1/128. I’ve not found another definitive reason not to. However, some out there would probably argue the point. The -2 was from a reddit post. (Not sure if that was linked in the forum post but here is if it’s not: http://www.reddit.com/r/UE4Devs/comments/246whl/the_most_important_thing_about_lightmaps/)

In most cases I would say 1/128 is perfectly fine, but there may be cases where you would want to use the 1/128-2. I’ve just not run into an instance where I cared enough to set my grid to that. :confused:

The test cases where people mostly point out the differences are with a single color base for you a wall where they can see the seams. If you set the Indirect lighting quality and smoothness in the world settings this should reduce it to the point when you have a legitimate diffuse on your mesh with normals and other details you shouldn’t see seams. Again, this is most cases and tweaking will be required.

Tim