What is this Error: The Skeleton metahuman_base_skel is missing bones that SkeletalMesh m_srt_unw_body needs. They will be added now.

I’m not sure what I did while customizing a Metahuman, but I can’t shake this error, and I can’t animate the body.

I’m using a 5.2 Metahuman that I’ve customized…and used clothing from the CitySampleCrowds. Clothing doesn’t seem to change the error.

I also can’t add animation to the body. It shows animations in the IK retargeter, but won’t work in Sequencer. Not sure if the two issues are related, but it seems like they are.

I have a very similar problem. I only customized my Metahuman’s hair but I get the exact same error. Animation works in retargeter but doesn’t work in sequencer. The head moves but the body doesnt. And I keep getting the metahuman_base_skel is missing bones that skeletal mesh needs. They will be added now please save skeleton

Hello
I had same problem twice
I solved this by:

  • first you must delete Metahuman_base skeleton (the skeleton is missing bones)
  • open Bridge and continue to My Metahuman
  • select current metahuman and hit blue Add
  • if you do attempt to retarget animation you will then see the animation in sequencer
    Worked for me