What is the reason and/or fix for UE5 (5.03 & 5.1) freezing my whole pc?


I’m an Unreal Engine artist and very dependant on the software to execute my profession and get my income.

As I’m working on projects that often have tight deadlines, crashes and things like that can be very stressful, but I’ve always been able to manage my way around those issues or deal with them head on.

Lately, I’ve been having an issue that I can’t really find a solution for though. Since a month or two ago my Unreal has been acting up (I think or maybe it’s a hardware issue). When working on projects (I have tried multiple projects) it often happens that my UE will get stuck and freeze, I can still operate the rest of my pc. But the moment I try to close UE or force quit it or any other option to close it, my whole computer freezes and the only way to get it to work is by hard resetting the pc… which I’ve done too many times by now.

Did anyone else experience this and now a solution or at least what the problem is? I’ve been looking around for a solution for a while now and haven’t found anything yet.

Thank you in advance to everyone offering help, I really appreciate it and hope we can find a solution!

All the best

I’ve been having the same issue, I haven’t found any solutions to it though, I even redownloaded version 5.0.3 and it still did it. I’ve never had this happen to me before either - opens projects the fine but after a few clicks maybe opening a mesh or something everything just freezes. Only thing I could think of maybe is wallpaper engine is using too much of my PC or it’s just a simple bug that needs to be patched? I personally don’t run any plugins either besides any ones that already come installed.

1 Like

Same problem here
From freezing on saving the project
To just moving a mesh
It is a hell and needs to be fixed fast
Because same as u this is the main program used for my job as level designer and if i cant make dealines it can cost my job
And im intrested on how mutch the take a look at these posts
I even changed all parts in my pc so i can confirm its not hardware based


Same here. I don’t need to take any action to make it happend. Just opened project and 30sec after UE freezing without any error.
My pc:
Ryzen 3700x
Raden RX 5700
Ram: 48gb

Same for me. I’ve been experiencing complete freeze of my computer with black screen “no signal detected” when I try to render. I’ve spent my all weekend on this issue, stress tested cpu/gpu but it does not seem to be a material issue. UE 5.1.

After one month of work and new projects to do this is a nightmare.

Same issue here. I’ve had 5 freezes today… GPU is not maxed out. Can happen just moving a static mesh.

Unreal 5.1.1 - 3XS Laptop, 64GB Ram, Geforce 3800 Ti

I am also facing this issue while using ndisplay and multiuser. All my cluster freezes at the same time. I’ve read things about multiuser acting up when saving without source control but it doesn’t sound like everyone is using these tools and still facing the same issue.

Hope this gets figured out fast as I am also reliant on the stability of Unreal Engine on set. Every freeze and reboot costs a lot of money when everyone is on the clock, and could discourage people from using virtual production in general.

1 Like

Just experienced what seems like the same issue.

Until recently, zero problems. Two weeks ago, I updated from 5.0.3 → 5.1.1. At first there was no problem, but in the last five days I’ve experienced two separate incidents where my entire computer froze up while interacting with UE, with no clear trigger.

Basically, the screen completely froze up and keyboard/mouse input also stopped registered. Music continued to play in the background, but after a while it began to get garbled. The same situation continued for a couple minutes at which point the only choice was to force a hard restart.

The Event Viewer and Reliability Monitor in Windows 10 didn’t show any interesting events other than an improper shutdown.

One thing that’s somewhat interesting is the last couple lines in the editor log from when the freeze happened:

[2023.02.26-08.33.46:309][670]LogD3D12RHI: Warning: GPU timeout: A payload (0x00000BE12CCE80A0) on the [0x00000BE11B785280, 3D] queue has not completed after 5.000000 seconds.
[2023.02.26-08.34.07:174][670]LogDerivedDataCache: (...)/UnrealEngine/Common/DerivedDataCache: Maintenance finished in +00:00:41.251 and deleted 0 files with total size 0 MiB. Scanned 21893 files in 21091 folders with total size 1401 MiB.

The GPU timeout warning is probably indicating that the GPU crashed in some way.

The fact that the derived data cache maintenance finished about 20 seconds after the timeout could possibly be some kind of hint? I don’t know what everyone else’s logs look like, but it would be useful to confirm whether these lines are consistent in each freeze.

By the way, I updated my AMD graphics driver to latest between the previous freeze and the current one, so it’s probably not an “update your graphics drivers” type of problem.

1 Like

Not neccesarily. There may have been additions to the Unreal code that cause a bug in the latest drivers. Most likely not, but a possibility nonetheless.

A driver “Roll Back” may be the answer. Obtain an older driver and try that instead.

My course of action would be:

  1. Use DDU completely remove all traces of your GPU drivers, even motherboard drivers (Important just as much)

  2. Get the latest driver(s) and re-install.

  3. Dont work? Rinse and repeat this time with older drivers

Yes tedious, but you do need to try something no?
Also check your XMP memory settings, reset them to basic, remove all overclocking.

Could be memory timing issues or just bad memory! It happens, dont just dismiss it say yours is fine. CHECK IT!

Each piece of hardware is different and they dont always play nice. You can’t just say its NOT a certain thing, especially drivers, as the latest and the past “x” iterations may still carry the issue thats causing it so sometimes going back is better!

That said I hope this helps, annoying? yes, worth trying? of course!


Good point. At the very least, I should try doing a full clean driver install and see if that has an effect.

For now, I deleted all my DerivedDataCache folders so that all shaders will recompile, and we’ll see if that does anything.

However, unlike other people in this thread, this issue seems to be occurring for me at a lower frequency than other people (twice total over the last week, among dozens of editor sessions), so it might take a while to reoccur. I’ll report back if I figure anything out.

1 Like

Full computer lockup happened again. Frozen screen, any kind of input impossible, but background audio from YouTube kept playing as if there was no problem. This time, it occurred while mousing over a (material?) asset in the Content Browser. The previous lockup occurred similarly I believe.

Nothing interesting in the log except the last two lines:

[2023.02.27-14.53.29:528][233]LogD3D12RHI: Warning: GPU timeout: A payload (0x000005C17C7D6820) on the [0x000005C16C0A0A80, 3D] queue has not completed after 5.000001 seconds.
[2023.02.27-14.53.29:528][233]LogD3D12RHI: Warning: GPU timeout: A payload (0x000005C17C041E00) on the [0x000005C16C0A1080, Compute] queue has not completed after 5.000000 seconds.

Seems like it’s most likely a GPU/driver issue, a motherboard issue, a UE 5.1.1 issue, or a combination of the above. Clearing the DerivedDataCache clearly didn’t do anything. For now, I guess I’ll try doing a graphics driver clean install.

Edit: Memoing down this miscellaneous tip I found online to try later in case the graphics driver clean install doesn’t help:

Open DefaultEngine.ini in your project’s Config folder and add these lines:

[/Script/WindowsTargetPlatform.WindowsTargetSettings] DefaultGraphicsRHI=DefaultGraphicsRHI_DX11

It solves lots of gpu related crashes in the recent version by deactivating DX12 features, including Nanite.

1 Like

I was going to suggest dx11 to see did it help?

The frequency of occurrence is quite low so I might not know for a while, but I will post again if I find anything out. The most recent lockup happened after a full day of otherwise uneventful work.

This has seemed to help for me, I’ve had the usual GPU crash a few times but no freezes.

Desktop shortcut > Properties >
Shortcut Tab > Run: Minimized
Compatibility Tab > Turn On - Disable fullscreen optimizations & Run this program as an administrator

I was skeptical but I’ve definitly seen improvements.


I have the same issue, but I thought problem was with my pc. Firstly I met full windows stuck when I needed to render 12k in 360 (I used dlss with max performance mode, but you all can understand how much pain it was) and almost usually when I start to render it windows just stops. There was logical reason - too less vram for 12k. But recently I met with same problem but in really random moments - mostly seems while compiling shaders, moving objects or camera. Im not sure it was after ue5. 1.1 or maybe even before, but now it become just a… It can stuck pc 10+ times per day, but only in some scenes - others work normally. But I found another problem - some games made the same thing (for example Marvels guardians of the galaxy) so here are 2 posibilities - windows again made some… And because of it there are such problems ( Im on Windows 10) or smth with drivers, as I think problem not only in ue5, but mostly in ue5. Also 1 question - how do you find scalabillity tab??? I dont have it, maybe because of windows 10…

And 1 more problem, not sure if it only with me, but when I render with sequencer since ue5. 1 and in resolutions more than 2k, but sometimes even in full hd - render have some very strange lags and sometimes half of the screen just flickering couple seconds, maybe someone have similar problem or have a solution, as also in some scenes it is in some not… But usually after 8k and 60fps+ resolutions all is okay

Alright, full system lockup happened again. This time it happened randomly when I left-clicked on a node in the MetaSound editor (maximized window).

So apparently doing a graphics driver full clean install (latest AMD version) and running chkdsk (with repair) on my SSDs didn’t help.

After four total lockups, all I’ve been able to narrow down so far is that:

  • It always happens while interacting with the Unreal Editor (UE5.1.1) itself - so far it hasn’t occurred in any other games or applications, or in packaged projects, or even in PIE mode (yet)
  • The system lock up is always the same phenomenon (frozen screen, input unresponsive, sound keeps playing, have to manually restart PC)
  • I have confirmed this editor log being output after every lockup: LogD3D12RHI: Warning: GPU timeout: A payload (0x0000080D3BD74600) on the [0x0000080D2A8D0A80, 3D] queue has not completed after 5.000000 seconds.

I guess next I’ll try the DefaultEngine.ini DX11 setting and see if that helps.
Edit: Changing to DX11 dramatically reduces my project’s framerate so unfortunately this isn’t an acceptable solution… Does anyone know a way to debug GPU crashes??

Edit: Looks like there are a lot of threads about GPU crashes in UE5. This one seems like it might be relevant so sharing it here: UE 5.1 gpu crashed or d3d device removed on AMD RX 6900 XT - #20 by SSLKGames - I’m going to try out this older driver version and see how it goes

This GPU memory leak report also seems like it could be quite relevant: GPU Dedicated Memory leak in DX12

I keep facing the same issue. My Unreal Engine Fully Freezes.

I checked the GPU profiling and I thought maybe this information would be useful.
It’s always some light that takes for example 800ms to render. It’s not a specific one though. It changes every time the crash occurs to one or two specific lights so don’t delete the lights because the light that takes too long to render always changes.

I have a 4090 and I’m still experiencing this. I even posted a thread about this. A sudden spike on GPU / 100% GPU use

Same issue here. I had this for a few months and a factory reset didn’t fix it. I then upgrades to windows 11 to see if that would stop it. It did for a while but Its just come back again same as last time. I changed my TDR I think its called(gpu time out) because substance painter wanted me to. I think this may have triggered it. I will know if this is my cause onces I take the time to try because the freezes aren’t so frequent.

Update - I havent fixed it, but I think this is because Raster Translucency… I know its strange, but I have 2 scenes in 1 project, that worked okay, then in one moment start crashing - turning on RTX translucency fixed the issue. And I working second day in City sample project - seems there isnt this problem + also very strange but when render in sequencer Vram is almost not using (even in 8k) while in usual projects I say hello to 22+ gb of Vram…

1 Like

I was ready to bin my computer when I started to encounter a similar phenomenon with a UE5.1 project freezing for 30+ seconds after just about any save or change in editor.

Every action in editor was also slow to kick off, and froze the editor after (opening assets, saving, attempting to close the project etc).

The simple act of closing an asset window would cause the editor to halt, with 0% CPU usage until the editor either came back to life a while later or crashed.

For me, this was the only project affected. I could run other UE projects in the background and the rest of my PC was working just fine.

I tried a heap of different things today, but in the end, the cause of the issue turned out to be bad data in my projects ‘Intermediate’ and ‘Saved’ folders.

The fix was the close the project and manually delete the contents of the ‘Intermediate’ and ‘Saved’ folders. You could also manually remove data from the ‘DerivedDataCache’ folder to be safe.

In my case, I also updated my Perforce setup to stop syncing these three folders from now on.

These folders are historically susceptible to causing issues and project slowdowns, especially after upgrading to new engine versions. It can be slow to regenerate the data again, but it’s often worth a try if your project is playing up.

I know this probably won’t help those with GPU troubles in this thread, but I hope it helps someone!

1 Like