What is the magical combination of settings for pathtracing?

…To get clean best possible output out of movie render queue from the pathtracer to be specific.

  1. If you want to have postprocess effects like bloom or DoF you cannot use denoiser or it will be denoising every given spatial number of samples and then do another temporal sample.

So no matter how many temporal samples you give the renderer it will result in a very blurry render.

You could try high amount of spatial samples but due to some memory leak or bug since 5.0.3(maybe even before) you will run out of memory.

  1. To get actually high amount of spatial samples you have to(counter-intuitively) set spatial to 1 and any high number of temporal samples AND disable multisampling effects.

Now you can also enable denoiser as it will only fire up on last temporal sample!

Great, but not much since now you don’t have bloom or depth of field. For whatever reason not even the reference depth of field works once you disable multisampling effects.

And one more thing. No matter what the settings are, you will never get sharp image. There is always some image filtering that blurs the image or some upscaling or whatever going on.

To see this difference compare any still taken from highresshot command to a frame from movie render queue. Happens on completely new projects as well and the difference exists at least since 5.0.3.

Is there someone who knows the magical combination or additional steps/settings to get clean renders and postprocess effects and high number of spatial samples from pathtracer?

To answer my own question, at least in 5.1 at this momet:

Using legacy movie render out of sequencer I am able to use pathtracer to:
A: get pixel sharp images, no blurry mess like MRQ
B: I will not run out of memory no matter what amount of spatial samples I set.

I really hope pathtracer+MRQ will get fixed for 5.1 cause even though there are multiple ways of getting stills from pathtracing only one works and it is a legacy setting that might disappear at some point.

Ok, spoke too soon. rendering out of sequencer has a problem of it’s own where it just won’t render the whole image :smiley: wtf…

EDIT: So if I render like 20 frames instead 1, I can get highres clean still frame :smiley: “Great”

Im in this same boat have you figured anything out? So frustrated its broken in 5.1 because i really want fog and decals in PT.

I was getting black bars like your and even completely black frames.

If I diable Multisample effect in MRQ it works but now I dont have ODF or anything.

Yes! I figured that if your scene has no moving parts that would invalidate pathtracing and force it to restart, you can set level sequencer legacy output to render something like 30 frames and even though first frames will be incomplete or black the latter ones will be ok!

So this way legacy output will just dump multiple frames that are same image and something like 5th or 6th frame could already be completely rendered out.

One another thing to watch out is that every time you start legacy output rendering the delay frame value in the setting will always jump to some weird number. So when I start rendering, while render is going on I change that number to something like 1 second or sometimes less. Otherwise you have to wait whatever time is in the delay for unreal to just save the output even though it was rendered.

Super annoying and weird workflow that no one possibly uses and no one ever should, but it is the only way you can get super clean and sharp pathtracing stills.