What I need to do to build and run on IOS

I used the c++ 3rd person template and followed the official tutorial on windows 10, but run into error in the end. It seems like I need use Xcode to compile the c++ code first, so I have to use mac. Is this true? I have a mac, but I just don’t like to switch between computers and the mac doesn’t have decent GPU and memory. So it’s just not ideal for game development…

In the editor open the Project Launcher (Window->Project Launcher) and find the iOS option. If remote build is setup correctly it will build and deploy. Might also be best is to expose the advanced settings and switch cook from on the fly to by the book.

You need to set your mac up to be used as a remote build machine.

Building for iOS on Windows

Thanks! I follow this steps and then what should I do? I am very newbie, thanks a lot!

Thank you so much!!

I followed the instructions but still go this, which looks just like remote build is not set up… What could go wrong?

Is the editor connected to the visual studio debugger?

I don’t really know… Everything is by default, I believe…

You’re running the editor through visual studio or opening it using the uproject file?

I used the uproject file

Looking at the error it seems like you need to build using visual studio. Could be something different, difficult to say without the full log file.

link text

That’s the full log. Thank you so much!!! I tried to package with windows64 and there is no problem.

Looks like you’re missing part of your Visual Studio install.

LogPlayLevel: WindowsPlatform.GetDefaultCompiler: WARNING: Visual Studio 2015 is installed, but is missing the C++ toolchain. Please verify that "Common Tools for Visual C++ 2015" are selected from the Visual Studio 2015 installation options.

Thank you so much of helping me! I can’t say how much I appreciated.
It seems like I just forgot to connect to the drive with VS installed… After I reconnected the drive, there is still error. :frowning:link text

I also tried on my Mac and I got this:
link text

I saw some posts saying on Mac, there is a bug in the engine, with ue4 14.4 and Xcode 8.3. Can't Deploy C++ Project on iOS - Mobile - Epic Developer Community Forums

The windows log that you’ve got there doesn’t look right. I’ve pasted the beginning of mine as comparison. Specifically you can see the remote connection occur in mine which is absent from yours. I’ve also attached an image of my iOS launch settings in the project launcher.


Thank you so much!

I still couldn’t figure out what’s wrong with my remote build, so I used my Mac to build. Since some posts say, ue4.14 + Xcode8.3 had some kind of bug, I upgrade my project to 4.16. Now, it seems having no build problem, but it has some signing problem…

I believe I set up the prevision and certs correctly…

Thank you so much man. I eventually made it working, although I didn’t know exactly what’s going on… Thank you so much for your generous help!!